LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Debian wheezy glitches while playback after upgrade (http://www.linuxquestions.org/questions/linux-software-2/debian-wheezy-glitches-while-playback-after-upgrade-4175429147/)

LeetShiva 09-26-2012 12:34 PM

Debian wheezy glitches while playback after upgrade
 
I run Debian Wheezy x86_64 and after upgrade to Wheezy from squeeze I have glitching sound sound with a lot of noise appearing when I play music in Clementine and Vlc. Vlc have that much of echo and noise that is not possible to watch to movie with it.

I can play music on pulse with DeadBeeF without glitches and noise and with Mplayer also videos without noise.

Output of lspci -v (part about audio device):
Code:

00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
        Subsystem: Giga-byte Technology Device a132
        Flags: bus master, slow devsel, latency 32, IRQ 16
        Memory at fe020000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Kernel driver in use: snd_hda_intel

When I run alsamixer version 1.0.25
I get message: This sound device does not have any playback controls.
which is weird because I have installed alsa.

I have checked simmilar thread on http://www.linuxquestions.org/questi...-sound-917079/ and there after trying to check did alsa work:
Code:

mplayer -ao alsa:device=default $FILENAME
I get this error:
Code:

==========================================================================
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 44100 Hz, 2 ch, s16le, 320.0 kbit/22.68% (ratio: 40000->176400)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
==========================================================================
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC1D0p' failed (-2): No such file or directory
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa:device=default'
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

running
Code:

dpkg-reconfigure alsa-base
doesnt help I still dont have working alsa.

I have tried to run module assistent and install alsa from source but it fails.

Can anyone help this is really annoying also to say I was just updating Gstreamer and installed version 1.0 than noise started I removed all gstreamer 1.0 packages and leave 0.10.

LeetShiva 09-26-2012 12:45 PM

It looks like my alsa config file on /etc/asound.conf was rewritten by some application and it was written
Code:

pcm.!default {
        type hw
        card 1
}
ctl.!default {
        type hw
        card 1
}

instead
Code:

pcm.!default {
        type hw
        card 0
}

ctl.!default {
        type hw         
        card 0
}

Dont know which package done that but now I have alsamixer working but I still have noise while playing Vlc and movies noise and echo.
Can I record that sound on some way to post it it sound really ugly.

LeetShiva 09-26-2012 12:56 PM

My Vlc is version
2.0.3-2 version from wheezy I have installed yauap that is command line gstreamer player to test is it a gstreamer problem and it play fine mp3 music. So it shouldnt be a gstreamer problem I checked this because I have trying to upgrade gstreamer on gstreamer1.0

Now only noise is produced by Vlc I have used Vlc for months and it was this same version I really dont know what is the error that make vlc produce noise instead of clear sound.

tux9656 09-26-2012 10:30 PM

I know this sounds drastic, but I suggest getting rid of pulseaudio altogether. If alsa + dmix works for you, there really is no reason to use pulseaudio. However, if you would like to continue using pulseaudio, perhaps vlc is configured to use alsa and pulseaudio is emualting alsa. This could be causing the noise. vlc should support outputting directly to pulseaudio. Check your setting in vlc to make sure it is set to pulseaudio and not alsa.

LeetShiva 09-27-2012 05:13 PM

I'm not sure on what you mean with dmix ?
 
I'm not sure on what you mean with dmix ?
Did you mean on something like this from alsa-project.org
Code:

pcm.!default {
        type plug
        slave.pcm "dmixer"
}

pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
                pcm "hw:1,0"
                period_time 0
                period_size 1024
                buffer_size 4096
                rate 44100
        }
        bindings {
                0 0
                1 1
        }
}

ctl.dmixer {
        type hw
        card 0
}

Do I need to change something for that to work ?

tux9656 09-27-2012 08:26 PM

I think alsa automatically uses dmix with sound cards that don't have a hardware mixer. There should be no configuration required.

LeetShiva 09-28-2012 10:52 AM

I have removed pulseaudio totally but now applications like clementine which uses gstreamer dont work properly
I mean it skip 40 songs when I click on new and throws error:

Failed to connect: Connection refused

tux9656 09-28-2012 04:47 PM

You may just need to reboot your machine after removing pulseaudio. Otherwise, run gstreamer-properties (or it might be gnome-gstreamer-properties or mate-gstreamer-properties if you run with mate) and select alsa as the output and input system.

LeetShiva 10-01-2012 01:49 PM

I fixed problem by following steps from "Pulseaudio perfect setup guide" http://www.freedesktop.org/wiki/Soft...r/PerfectSetup

Damn it I feel foolish that I didnt checked that before.

It was just simple change in asound.conf file:

Code:

pcm.!default {
    type pulse
    # If defaults.namehint.showall is set to off in alsa.conf, then this is
    # necessary to make this pcm show up in the list returned by
    # snd_device_name_hint or aplay -L
    hint.description "Default Audio Device"
}
ctl.!default {
    type pulse
}



All times are GMT -5. The time now is 08:45 AM.