LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-14-2008, 02:48 PM   #1
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Rep: Reputation: 15
debian etch to lenny dist-upgrade broke X for current user.


Today I did an apt-get dist-upgrade from debian etch to lenny. seems to work great except that my regular user account startx then immediately closes. There are also warnings about could not init font path elements. Using root or any other account I can startx fine. There are no error messages in /var/log/Xorg.0.log. This seems like a permissions issue or something simple, but I do not know what to check. I am used to slackware where if something broke, you knew what it was...

Thanks
 
Old 11-14-2008, 04:24 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
It's something simple like you need new drivers, or you forgot to install a DM, or xorg didn't install correctly. You shouldn't be able to log into an X session as root. You must have done something wrong there, but since you're such an expert Slackware user, I'm sure you can figure it out.
 
Old 11-15-2008, 12:50 PM   #3
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Original Poster
Rep: Reputation: 15
Don't mean to be an *** but that reply seems a bit caustic. For the past two years or however long I have come here for help I have never been greeted like that. We try to help each other here, don't we?

Anyway, since when can root not start x? X starts correctly for other users. I have seen similar problems when using gnome (I have broken the current user's gconf or something). I am not using gnome or kde here though, just fluxbox. I am by no means a slackware expert it is just what I have used for the longest time. Maybe I gave the impression that i was using a login manager (xdm, gmd, kdm - by default root can not log in with those) but I am not, I prefer to log in to console then startx when I want to. For me this has a few advantages .. if I break X (which happens a lot because I can never leave stuff alone )I can still log in to work on stuff without a livecd, etc

I don't really think I did anything wrong. I had a fully functional system and did a dist-upgrade. I know in the world of Ubuntu that normally causes problems (for my brother at least). I thought maybe debian would be better about that. As I was saying everything works great with the new kernel and new packages. Maybe I just have something in one of my regular users hoem directory configuration files that just freaks out the new stuff?? I don't think it is xorg.conf becasue X works fine for other users. This problem seems like it would be really easy to solve, can someone point me in the right direction? I suppose I could just create a new user and use that the copy all my files over and fix permissions but I don't learn much by doing that...

Last edited by pauledwards03; 11-15-2008 at 01:01 PM.
 
Old 11-15-2008, 01:15 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Quote:
It's something simple like you need new drivers, or you forgot to install a DM, or xorg didn't install correctly.
Strike "or you forgot to install a DM"

Quote:
It's something simple like you need new drivers, or xorg didn't install correctly.
Slurring Debian with comments like ... "I am used to slackware where if something broke, you knew what it was." are an open invitation to flames. On the Debian boards, it could get you (figuratively) tarred and feathered.

Debian, by default, generally disables GUI logins by root. Since you did an upgrade rather than a fresh install, it's likely that your xorg.conf file is messed up. Normally, this would not be an issue, but with Lenny under intensive development, strange things come and go right now. When Lenny is released there will be release notes to point out potential problems, as of now there are not, so it makes sense to upgrade carefully.
 
Old 11-15-2008, 02:34 PM   #5
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Original Poster
Rep: Reputation: 15
I did not mean to say anything bad about debian, in fact debian potato I think was my first introduction to linux. I have always approached distribution upgrades with caution. I do prefer to do clean installs, other than this small X issue, the upgrade went very well. I will post my xorg.conf when I get back to the office on Monday.

This may be relevant: I did not do a regular install of etch, I used the netisnt disc and only installed X and fluxbox (and other stuff like gtk and such). The machine I am using is a bit antiquated by today's standards, so I like using only what I need.

Last edited by pauledwards03; 11-15-2008 at 02:40 PM.
 
Old 11-17-2008, 07:51 AM   #6
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Original Poster
Rep: Reputation: 15
Hello again, here is my xorg.conf:
The only thing I have modified is adding the composite extension and the modeline to get 1280x768.

Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath	"/usr/share/fonts/X11/misc"	
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
	Load    "dbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"intel"
	BusID		"PCI:0:2:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	50-70
  # 1280x800 @ 75.00 Hz (GTF) hsync: 62.62 kHz; pclk: 107.21 MHz
  Modeline    "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
DisplaySize 433 260

EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Section "Extensions"
	Option "Composite" "Enable"
EndSection
 
Old 11-17-2008, 08:59 AM   #7
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Original Poster
Rep: Reputation: 15
This was not an X problem, nor a permissions issue. All it was was the new version of fluxbox used different configuration files. namely, I now have a ~/.fluxbox/startup, whereas before I did not. Previously I created a file called ~/.fluxbox/startup to house my startup commands. With the new version of fluxbox, my conflicting files just freaked it out I guess. The solution was to merge the contents of my old startup file into the new one. Knowing this, I have to applaud Debian on this upgrade (especailly to unstable!). :-D
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How I've dist-upgraded etch->lenny->sid without problems aleTT Debian 15 08-20-2008 05:15 AM
dist-upgrade to lenny is not working Cyberman Debian 3 08-16-2008 12:19 PM
Dist-Upgrade from the Current Lenny to Sid Zaskar Debian 2 08-28-2007 05:05 PM
How to resolve unmet dependencies in dist-upgrade from debian sarge to etch maxmil Linux - Software 8 01-30-2007 05:33 AM
Debian Sarge Dist-Upgrade to Etch... now NO GDMSETUP to be found. freetime000 Linux - Software 2 04-08-2006 08:49 PM


All times are GMT -5. The time now is 04:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration