LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-24-2004, 03:23 PM   #1
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
debian dpkg cpp depends on cpp error


Since I don't have internet (can't do that cause I need to update the kernel first) and I'm running a minimal installation I'm downloading loose packages and installing them with dpkg.

Now I'm trying to install cpp. I don't have the complete error msg but it goes like:

extracting - ok
error cpp depends on cpp-2.95 (i'm installing this version)
cpp not installed
cpp not configured

Also if I run dpkg --pending --configure it gives the same error. I tried to do it via dselect with the same results. What dselect does show is that cpp is installed onlynot configured. How can this happen (that the package depends on itself or something) and more important how can I fix it?
 
Old 06-24-2004, 04:04 PM   #2
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
Well, the trick is that:

Package cpp (version 2.95-something or something:2.95-something; file named as cpp_2.95-something_i386.deb) do really depends on package called cpp-2.95 (probably also version something:2.95-something, the file is named as cpp-2.95_2.95-something_i386.deb)

Why this is so utterly complex? Well, the idea behind all this is that "cpp" is a meta package that depends on the c preprocessor version that is default preprocessor of current distribution (2.95 on stable, 3.3 on testing/unstable on i386 architecture). In many cases (eg. when developing software) one needs many versions of cpp to coexist in the system; most importantly because gcc 2.95 and 3-series is not fully source-level compatible and the object format of c++ files has changed in 3.0. So, one can install eg. cpp-3.0 to have preprocessor version 3.0 available as "cpp-3.0" (the cpp is just a symlink to some cpp version (whichever is the default for distribution)) and when one installs just "cpp" he gets the default version.

How to fix the problem?
Fetch and install the cpp-2.95 package first, then cpp.
 
Old 06-25-2004, 01:47 AM   #3
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
Thanks for the help and explanation!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cpp error ashirazi Programming 1 09-18-2004 05:49 PM
Chitin.cpp error abk4523 Linux - Games 0 09-12-2004 10:17 AM
CPP error, please help... TomAL Mandriva 3 12-24-2003 09:57 AM
cpp error ANU Linux - Software 1 12-05-2003 11:24 PM
Now I have gcc/cpp/cpp, but still can't install sfingerh Linux - Software 2 07-30-2002 03:13 AM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration