LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   dBus-1.0.2 installation problem (http://www.linuxquestions.org/questions/linux-software-2/dbus-1-0-2-installation-problem-610577/)

angelwood 01-02-2008 07:56 AM

dBus-1.0.2 installation problem
 
:newbie:

Hello! Happy New Year, everyone! :D Linux and forum newbie here. Would really appreciate anyone's help on this one.

I was planning on installing Skype and found out that it has 4 requisite files:

# Qt 4.2.1+
# D-Bus 1.0.0
# libsigc++ 2.0.2
# libasound2 1.0.12

I installed Qt and it worked just fine, but when I tried installing dBus-1.0.2, I encountered some error messages and could no longer log in after a reboot. :eek: The message box said:

Quote:

Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem.
The .xsession-errors file that goes with it says:
Quote:

/etc/x11/gwm/PreSession/Default: Registering your session with wtmp and utmp
/etc/x11/gwm/PreSession/Default: running: /usr/bin/x11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "var/gdm/:0.xservers" -h "" -1 ":0" "angel"
Agent pid 3276
Failed to start message bus: Failed to open "/etc/selinux/targeted/contexts/dbus_contexts": No such file or directory
EOF in dbus-launch reading address from bus daemon
When I tried starting gnome-session using the failsafe terminal, this was part of what was written on the terminal:

Quote:

** (eggcups:19556): CRITICAL **: couldn't connect to session bus: Unable to determine the address of the message bus
but Gnome did start, and now I am typing this. I don't even know where to start. I thought maybe I should try uninstalling then reinstalling dBus. I checked the requisite files for dBus, and my system has expat so I'm not sure what the problem is. Should I get the latest version of expat before reinstalling dBus? Should I try installing pkg-config-0.22 and libxml2-2.6.29 instead?

Can someone please interpret all these for me please?!? :confused: I really don't understand any of it. :o I've only been using Linux 2.6.9 (Fedora) for about a year, and I'm not familiar with the commands.

Thanks for your time and whatever help you experts can extend to me. May God bless you! :)

Lenard 01-02-2008 08:20 AM

Quote:

Linux 2.6.9 (Fedora)
Fedora Core 3 is not supported, get yourself a modern supported version of Linux. If staying with the Red Hat / Fedora family then may I suggested either CentOS or Fedora 7 / 8.

http://www.linuxquestions.org/questi...-linux-524947/

Skype is supported for both and there are rpm packages available for both CentOS 5.x or Fedora 7/8(use the Fedora 7 Fedora Core 6 skype-1.4.0.118-fc5.i586.rpm package).

http://www.centos.org/
http://fedoraproject.org/

It is a lot of work to get dbus > 1 working on FC3, you need to update just about everything in order to accomplish this task (the kernel, hal for starters need to be updated). it is a lot easier and quicker to install a modern supported version of Linux.

angelwood 01-02-2008 09:08 AM

Thanks!
 
Thank you, Lenard, for your prompt reply. Am a bit hesitant to upgrade my OS since I've never done it before. Thank you for the links. I'm checking them out right now.


All times are GMT -5. The time now is 12:43 PM.