LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-07-2005, 02:54 AM   #1
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
Date display in Thunderbird


Does anyone know how -if it is possible - to change the date format in Thunderbird?

Currently, everything is coming out in US format - highly confusing to a European like me ;-)

What I would like is to set it per ISO8601 (yyyy-mm-dd).

I'm quite happy to hack files in my .thunderbird directory if required, but am not really prepared to re-compile just to fix something that I feel should be under 'Preferences'...

Cheers

Matthew
 
Old 04-07-2005, 08:28 PM   #2
Randall Slack
Member
 
Registered: Feb 2005
Location: Rotterdam, The Netherlands
Distribution: Debian - Ubuntu
Posts: 219

Rep: Reputation: 30
Hi Kbc,

i've been looking for the same thing a while ago when using it on windows, and found out (at that time), that it wasn't possible from within thunderbird.
Thunderbird uses the default settings of your OS, when simply changing the date and time format of your OS, thunderbird will coppy this.

Please note this was with Thunderbird 1.0 under windows. but maybe you can try to look in that direction.
 
Old 04-08-2005, 05:31 AM   #3
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Original Poster
Rep: Reputation: 15
Hi Randall

Thanks for that idea; I've checked the date/time settings, which are for Australia - same format as Europe.

The must have put it somewhere else in the Linux version - maybe I will have to compile my own after all

Cheers

Matthew
 
Old 04-08-2005, 07:27 AM   #4
Randall Slack
Member
 
Registered: Feb 2005
Location: Rotterdam, The Netherlands
Distribution: Debian - Ubuntu
Posts: 219

Rep: Reputation: 30
Hi kbc,

sorry to hear it doesn't work, i'm planning to use thunderbird on my linux as well, so i'm afraid i'll bump into the same problem. in case you find an answer, i'd be happy to hear it.
 
Old 04-08-2005, 08:45 AM   #5
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
To get round it, I added this to /etc/profile (or you could add it to ~/.profile):
Code:
export LC_ALL=en_GB
although
Code:
export LC_TIME=en_GB
would I believe have the same effect.

(In the case of Australia, the correct setting is "en_AU". 'locale -a | egrep "en*"' will give you a full list of all locales for English speaking countries. 'locale' will display your current locale settings).

Edit

Randall - for the Netherlands, the correct locale is nl_NL. In Slack, you can either edit /etc/profile, or edit both /etc/profile.d/lang.sh and /etc/profile.d/lang.csh

Last edited by cathectic; 04-08-2005 at 08:51 AM.
 
Old 04-08-2005, 08:27 PM   #6
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Original Poster
Rep: Reputation: 15
Thanks Carlos!

I've had a poke around - SuSE users (on 9.0 at least) can set these in /etc/sysconfig/language and run SuSEconfig.

It's opened up a can of worms for me - I'm now looking to have to create my own locale to get my desired (ISO) date format into my (en-AU.UTF8) locale - all good fun!

Cheers

Matthew

Last edited by kbcnetau; 04-08-2005 at 08:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving from Thunderbird in Windows to Thunderbird in Linux pnh73 Linux - Software 14 11-05-2011 09:24 AM
Thunderbird Date Format dotancohen Linux - Software 9 10-15-2005 02:55 PM
Force Thunderbird to always display in text? predator.hawk Linux - Software 1 12-02-2004 12:14 PM
Display the date and time from another time zone lothario Linux - Software 4 07-31-2004 03:27 PM
lastlog date does not match system date? jcmj Linux - Networking 6 10-22-2002 12:09 PM


All times are GMT -5. The time now is 06:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration