LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-15-2004, 06:26 PM   #1
JulesVerne
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake and Debian
Posts: 5

Rep: Reputation: 0
DataRequest Error


Hello everybuddy
I have a MSI 875p Neo and bought a Maxtor 120 GB SATA disc. Then I booted knoppix 3.3, mounted the disc, placed an ext3 fs on the disc and all my data. I used the disc few times but a few days later I suddenly couldn't mount the partition anymore. It kept telling me about a corrput superblock.

so I did: "mke2fs -n /dev/hde1"
It told me where the backups of the superblock are.

Then I tried: "mount -o sb=32768,ro -t ext3 /dev/hde1 hde1".
Linux answered the following:

"hde: read_intr: status=0x59 {DriveReady SeekComplete DataRequest Error}
hde: read_intr: error=0x40 {Uncorrectable Error}, LBAsect=65, sector=2
end_request: I/Oerror, dev 21:01(hde),sector2
EXT3-fs: unable to read superblock
mount: wrong filesystemtype," etc etc ... the rest is just the normal mount-error-message.

I tried to use "-t ext 2" instead of "-t ext3" but it didn't change the result.
Also PartitionsMagic 8 says "bad disc".

Please please help me - the data is pretty important and [shame on me] there is no backup!

Thanks for your help!
JulesVerne
 
Old 01-15-2004, 07:47 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
I suggest that you try to clean up the file system with fsck.ext3. You probably will have to run fsck.ext3 from a rescue CD.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 01-16-2004, 09:07 AM   #3
JulesVerne
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake and Debian
Posts: 5

Original Poster
Rep: Reputation: 0
I tried - but it ended up throwing error messeges at me .. too much to write them down or even read them and I couldn't stop him from doing so (crt+c didn't work - I had to reboot the computer to stop it).
First it said that the journal had to be deletet in inode 8, I said yes. Then it said something about another inode error, I said yes again. After that there were those endless errormessages (which seemed to be the same, that came when I tried to mount it (in single user mode)). The only thing that was long enough displayed to be readable was something like "interrupt 10 error, resetting drive". That message came pretty often.
I am very well confused now... :-(
 
Old 01-16-2004, 11:16 AM   #4
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
You may have a bad spot on the disk surface. Schatoor had a problem like that. He eventually solved the problem but not before he had erased all of his data. He posted the solution to the problem at the end of his thread in case anybody else needed the answer.

http://www.linuxquestions.org/questi...hreadid=129259

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
updating new installation of 9.3 ERROR...ERROR...ERROR Morbid SUSE / openSUSE 3 08-16-2005 12:22 AM
kudzu error loading libraries & respawning too fast error CatherineBennet Linux - Newbie 0 01-05-2005 06:04 PM
{ DriveReady SeekComplete DataRequest Error } kelnt Linux - Hardware 2 11-26-2004 08:38 AM
Hard drive failure error? (sense key Medium error) Arodef Linux - Hardware 2 11-02-2004 01:39 PM
GRUB error? DriveReady SeekComplete DataRequest Error sth Linux - Hardware 3 02-26-2003 06:10 PM


All times are GMT -5. The time now is 12:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration