LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-10-2006, 10:21 AM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Rep: Reputation: 83
Question dapper: amarok doesn't want to play mp3s


I updated from breezy to dapper, but amarok doesn't want to play mp3s after the upgrade. I'm using the same engine I had in breezy: xine (through alsa), but it doesn't play the mp3s. Goes through them very fast, say half a second for each mp3 an that's it, no sound.

What piece of the puzzle did I skip?

By the way, I tested alsa with mplayer at it's working normally... aparently.

Last edited by eantoranz; 03-10-2006 at 10:22 AM.
 
Old 03-10-2006, 12:14 PM   #2
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Rep: Reputation: 30
Is there a special plugin for amarok in order to play mp3s? You may want to search synaptic after you've added extra repositories. If you're running it on the xine engine, check for an xine mp3 plugin.

Just a thought.
 
Old 03-11-2006, 07:33 PM   #3
[42]Sanf0rd
Member
 
Registered: Apr 2004
Location: Dallas, TX
Distribution: Open Suse 10.2
Posts: 50

Rep: Reputation: 15
has anyone found a solution to this? I have Suse10 on both my computer and my girlfriend's, and for some reason mine will play MP3 files perfectly, but hers will play every audio format EXCEPT for MP3, which, of course, is what she wants to listen to (obviously)

i try to recompile the XINE libs, but it keeps saying:

Code:
configure: error: zlib needed
but zlib IS in fact installed (i've checked through YAST and Synaptic and they both verify this)

any suggestions? i still don't know why it works perfectly on my machine but not at all on hers, when it's the same distro (same CD as a matter of fact).

Only real difference is that mine's a 32 bit proc and hers is a 64, but to make Cedega work, I had to install the 32 bit version of Suse10. I don't think that hardware could be the issue though, since her sound works perfectly with WoW (through Cedega), Quake III, Quake IV, etc (yes, my girlfriend is a gamer who uses linux... how lucky could i be, eh?)

anyway, if anyone has some suggestions as to why Amarok won't play MP3's, please let me know.

Thanks,


Sanford
 
Old 03-12-2006, 10:28 AM   #4
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
now, strangely I just updated my home laptop with dapper (just like the office's computer) and guess what.... I got amarok to play mp3s right away. It's pretty weird that the office's doesn't. I think I'll have to dig a little further.
 
Old 04-01-2006, 10:58 PM   #5
linguizic
LQ Newbie
 
Registered: Sep 2004
Location: Oxford, MS
Distribution: Ubuntu64
Posts: 5

Rep: Reputation: 0
I don't know how many times I've had things like that happen to me. It's the same with every distro I've ever used (which is more than a few at this point). It seems that for some reason putting the same distro (same CD) on different hardware produces different results. I don't know if any of the BSD's have that problem, but it seems that it's quite common in linux. One of the reason's why I now use Ubuntu is because it seems to do that less.
 
Old 04-05-2006, 01:25 AM   #6
roquediego
LQ Newbie
 
Registered: Apr 2006
Location: Guadalajara Mexico
Distribution: Suse 9.1 , Suse 10
Posts: 5

Rep: Reputation: 0
amarok

well i just install suse 10 and i cant play any mp3 or music cds but i can hear anyother sounde any idea whats going!???
 
Old 04-05-2006, 10:47 AM   #7
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Probably you have to tell your multimedia player to use the right "engine", say: alsa, oss, arts, esd, gstreamer, etc etc
 
Old 04-05-2006, 10:50 AM   #8
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
By the way, I was finally able to play mp3s. I needed to install one package:

libxine-extracodecs I think.
 
Old 07-15-2006, 02:54 AM   #9
mifanc
LQ Newbie
 
Registered: Mar 2005
Location: Sri Lanka
Distribution: Debian
Posts: 2

Rep: Reputation: 0
yep. it seems libxine-extracodecs is the solution. but the dissapointing fact is that amarok-gsteamer seems to be MIA in dapper , so you cannot use the gsteamer engine!
 
Old 07-15-2006, 03:02 PM   #10
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
I'm using the xine engine since some time ago. You need to install some other package to make xine be able to play mp3s... but it does work.... libxine-extracodecs, I think. Hope it works for you. :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Would this work to sync my mp3s using amarok? zeroz52 Slackware 4 09-30-2005 10:17 PM
Is it possible to play mp3s on Amarok ? Virp00 Suse/Novell 4 07-20-2005 08:31 PM
suse 9.3 amarok and xmms can't play mp3s dvm Suse/Novell 2 05-07-2005 07:03 PM
amaroK doesn't like some of my mp3s. mdj Linux - Software 1 03-22-2005 09:59 AM
Cannot play MP3s Inuyasha-kun Linux - Newbie 7 12-08-2003 09:52 PM


All times are GMT -5. The time now is 05:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration