LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-16-2004, 11:59 AM   #1
hellblade
Member
 
Registered: Jan 2004
Location: Greece
Distribution: Debian Sid
Posts: 58

Rep: Reputation: 15
Custom kernel supporting "vga=791"


What should I enable in my kernel configuration to have console in vga=791 mode?
Using the debian pricompiled kernels I can do it but no matter what I try with my own kernel I can't.

I use grub as bootloader, configured properly because as I said the pricompiled kernels work fine.
 
Old 09-16-2004, 12:17 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
You need VESA framebuffer support.

In the 2.6 kernel configuration make sure you have these built-in:
Device drivers --> Graphics support: "Support for framebuffer devices" and "VESA VGA graphics support"
Device drivers --> Graphics support --> Console display driver support: "Video mode selection support" and "Framebuffer console support".

That should do it.

Håkan
 
Old 09-16-2004, 03:56 PM   #3
hellblade
Member
 
Registered: Jan 2004
Location: Greece
Distribution: Debian Sid
Posts: 58

Original Poster
Rep: Reputation: 15
I have them built-in my kernel (not even modules) but it doesn't work.
Could the problem be that I have also built-in the ATI Radeon driver?
 
Old 09-16-2004, 04:47 PM   #4
95se
Member
 
Registered: Apr 2002
Location: Windsor, ON, CA
Distribution: Ubuntu
Posts: 740

Rep: Reputation: 32
As said above, in the "Support for framebuffer devices" section choose "VESA VGA ...", the other ones (when I have the Vid. card) haven't worked for me yet. So instead of Radeon, try VESA.
 
Old 09-16-2004, 06:04 PM   #5
hellblade
Member
 
Registered: Jan 2004
Location: Greece
Distribution: Debian Sid
Posts: 58

Original Poster
Rep: Reputation: 15
If I choose only the VESA driver I won't have 3d acceleration with my card (ATI Radeon 9000).

Isn't there any way to enable both drivers in my kernel but use VESA for my console and Radeon for the xfree?
 
Old 09-16-2004, 07:02 PM   #6
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
I have never been in your situation, but read up on radeonfb. I think it can do high resolution console. Instead of using vga=791, try something along the lines of "video=radeonfb:1024x768-32".


Håkan

Last edited by hw-tph; 09-16-2004 at 07:05 PM.
 
Old 09-16-2004, 07:35 PM   #7
hellblade
Member
 
Registered: Jan 2004
Location: Greece
Distribution: Debian Sid
Posts: 58

Original Poster
Rep: Reputation: 15
thanks. I'll take a look at it and see if it works.
 
Old 09-16-2004, 08:39 PM   #8
hellblade
Member
 
Registered: Jan 2004
Location: Greece
Distribution: Debian Sid
Posts: 58

Original Poster
Rep: Reputation: 15
OK.
I found there are 2 solutions:
1. to add 'video=radeonfb:1024x768-16@60 video=vesafbff'
2. to add 'video=radeonfbff video=vesafb vga=791

As I want the bootsplash feature and the first one has some problems with that I will use the second one that does the job well.

Thanks again for your replies!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB "vga=" option and OpenGL performance NeoChaosX Linux - Software 1 06-19-2005 01:56 AM
how can i change my vga driver from "vesa" to "savage" mojarron Slackware - Installation 1 03-24-2005 11:03 PM
how can i change my vga driver from "vesa" to "savage" mojarron Slackware 1 03-24-2005 07:16 AM
vga=791? (part 2) zecodela Linux - Software 6 10-27-2004 10:00 AM
Fedora X-server not supporting "millions of colours" harsha_vardhan Linux - Newbie 5 01-23-2004 12:08 PM


All times are GMT -5. The time now is 03:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration