Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-21-2004, 07:46 AM   #1
LQ Newbie
Registered: Mar 2004
Location: Tampere, Finland
Distribution: Gentoo 2004.3, Ubuntu
Posts: 15

Rep: Reputation: 0
Question curl "incompatible pointer type" while making PHP


so far I've managed to get PHP's configure script pass, but while mak(e)ing PHP, I run to the following error:

[root@a155t4 php-5.0.0RC1]# make
/bin/sh /root/php-5.0.0RC1/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/curl/ -I/root/php-5.0.0RC1/ext/curl/ -DPHP_ATOM_INC -I/root/php-5.0.0RC1/include -I/root/php-5.0.0RC1/main -I/root/php-5.0.0RC1 -I/root/php-5.0.0RC1/Zend -I/usr/local/ssl/include -I/usr/local/include -I/usr/include/mysql  -I/root/php-5.0.0RC1/TSRM  -g -O2  -prefer-pic -c /root/php-5.0.0RC1/ext/curl/interface.c -o ext/curl/interface.lo
/root/php-5.0.0RC1/ext/curl/interface.c: In function `curl_free_post':
/root/php-5.0.0RC1/ext/curl/interface.c:655: warning: passing arg 1 of `curl_formfree' from incompatible pointer type
/root/php-5.0.0RC1/ext/curl/interface.c: In function `alloc_curl_handle':
/root/php-5.0.0RC1/ext/curl/interface.c:723: sizeof applied to an incomplete type
/root/php-5.0.0RC1/ext/curl/interface.c: In function `zif_curl_setopt':
/root/php-5.0.0RC1/ext/curl/interface.c:1008: duplicate case value
/root/php-5.0.0RC1/ext/curl/interface.c:853: previously used here
/root/php-5.0.0RC1/ext/curl/interface.c:1050: warning: passing arg 1 of `curl_formadd' from incompatible pointer type
/root/php-5.0.0RC1/ext/curl/interface.c:1050: warning: passing arg 2 of `curl_formadd' from incompatible pointer type
/root/php-5.0.0RC1/ext/curl/interface.c:1057: warning: passing arg 1 of `curl_formadd' from incompatible pointer type
/root/php-5.0.0RC1/ext/curl/interface.c:1057: warning: passing arg 2 of `curl_formadd' from incompatible pointer type
make: *** [ext/curl/interface.lo] Error 1
[root@a155t4 php-5.0.0RC1]#
My curl is now version 7.9.8, the newest rpm I could find. I've also tried making PHP with a compiled curl 7.11.1 (the newest).

Any help is appreciated!
Old 04-02-2004, 05:32 PM   #2
LQ Newbie
Registered: Apr 2004
Location: US
Distribution: RedHat
Posts: 1

Rep: Reputation: 0
I had the same problem.

Use curl 7.11.0 instead. Based on PHP post

You can get old curl here:

Old 04-15-2004, 11:21 AM   #3
LQ Newbie
Registered: Jun 2003
Posts: 3

Rep: Reputation: 0
For the record, I'm having the same problem with php-4.3.5 using older curl (curl-7.8.1). Too many dependencies on production machine to risk "upgrade" to later version of curl.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
"...incompatible pointer type" Can it be ended? lyd Programming 3 07-29-2005 03:43 PM
C error "dereferencing pointer to incomplete type" lucs Slackware 6 02-21-2005 10:33 AM
How does one surpress incompatible pointer type warnings? tonyfreeman Programming 1 08-18-2004 07:06 PM
Getting an incompatible pointer type error... JStew Programming 4 03-06-2003 06:08 PM
Installing Wine - incompatible pointer type orange400 Linux - Software 1 03-03-2003 01:57 AM

All times are GMT -5. The time now is 03:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration