LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-06-2004, 04:43 PM   #1
jmlleung
LQ Newbie
 
Registered: Mar 2004
Location: California
Posts: 9

Rep: Reputation: 0
CUPS USB not working on Brother HL-1440


I installed CUPS 1.1.20 on my Dell PowerEdge 400SC. I use Red Hat Linux 9.

At first I connected my Brother HL-1440 printer to the second USB slot on the first row. When I tried to test print, it said something like "idle, accepting jobs". But nothing get printed.

After I searched the internet, I did two things:
1. I switched the printer to the first USB slot on the second row
2. I add this line to the end of /etc/fstab:
none /proc/bus/usb usbfs defaults,devmode=0666 0 0

The Printer State changed to "Media tray empty!" from "idle, accepting jobs". Hmmm..., after doing something else, now the Printer State is "Ready to print." However, I tried to test print but still nothing comes out.

I delete the Printer and add it back. Now it is "idle, accepting jobs" but nothing printed out again.

Is this a bug? Can someone help?

Thanks,
Johnson
P.S.: Another question: I cannot use usb:/dev/usb/lp1. When I try to do that, it said "Unable to open USB device "usb:/dev/usb/lp1": No such device"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New brother DCP 110C printer not working CUPS babil Linux - Hardware 8 07-03-2005 08:24 AM
Brother HL-1440. Have to start printer to print. mooreted Slackware 1 02-03-2005 12:42 AM
Brother laser printer not working with fc2 tzonga1 Linux - Hardware 0 12-12-2004 09:20 PM
HL-1440: USB connection lost mooreted Slackware 4 12-12-2004 11:50 AM
brother 1440 geekdug Linux - Hardware 2 03-10-2003 09:51 AM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration