LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   CUPS - Queue Limit (http://www.linuxquestions.org/questions/linux-software-2/cups-queue-limit-731682/)

sectioneight 06-09-2009 10:44 AM

CUPS - Queue Limit
 
Hello,

I seem to keep running into a limit in CUPS that only allows ~500 print jobs in the queue at one time. I'm not sure how to raise it.

I am running Redhat Enterprise Linux 5.
Name : cups
Arch : i386
Epoch : 1
Version : 1.3.7
Release : 8.el5_3.6
Size : 9.8 M
Repo : installed

Thank you for your time.

sectioneight 06-10-2009 12:05 PM

Can anyone take a smack at it?

farslayer 06-10-2009 01:40 PM

It's in the Docs for cupsd.conf...


http://localhost:631/help/ref-cupsd-...=queue#MaxJobs

Quote:

MaxJobs

Examples

MaxJobs 100
MaxJobs 9999
MaxJobs 0

Description

The MaxJobs directive controls the maximum number of jobs that are kept in memory. Once the number of jobs reaches the limit, the oldest completed job is automatically purged from the system to make room for the new one. If all of the known jobs are still pending or active then the new job will be rejected.

Setting the maximum size to 0 disables this functionality. The default setting is 500.


MaxJobsPerPrinter

Examples

MaxJobsPerPrinter 100
MaxJobsPerPrinter 9999
MaxJobsPerPrinter 0

Description

The MaxJobsPerPrinter directive controls the maximum number of active jobs that are allowed for each printer or class. Once a printer or class reaches the limit, new jobs will be rejected until one of the active jobs is completed, stopped, aborted, or canceled.

Setting the maximum to 0 disables this functionality. The default setting is 0.




MaxJobsPerUser

Examples

MaxJobsPerUser 100
MaxJobsPerUser 9999
MaxJobsPerUser 0

Description

The MaxJobsPerUser directive controls the maximum number of active jobs that are allowed for each user. Once a user reaches the limit, new jobs will be rejected until one of the active jobs is completed, stopped, aborted, or canceled.

Setting the maximum to 0 disables this functionality. The default setting is 0.


btw replying to your own post to bump it disables the automated bump feature and removes your post from the Zero reply list. so in attempting to gain more exposure for your post, you actually reduced it's exposure, by defeating the built-in Forum features that are there to assist you..

Just fyi for the future. .

sectioneight 06-10-2009 03:25 PM

Thanks for your reply. I did not realize that about writing the 2nd post, I just saw there were 50 views and no one had replied. (I didn't even see how far down the list I was, I just clicked on "My Posts")

I didn't even think to try man cupsd.conf, with all the google searching I did I can't believe I did not come across that setting.

Thank you very much for your help, you guys do a great job!

farslayer 06-10-2009 09:29 PM

I actually pulled that from the manual via the web interface that is on your PC when you install cups..

http://localhost:631

then click the documentation/Help link :)

Cheers !!


All times are GMT -5. The time now is 08:49 PM.