LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-02-2005, 11:16 AM   #1
Bigun
Member
 
Registered: Aug 2002
Location: Hickville, TN
Distribution: Gentoo > current. Have used: Red Hat 7.3, 9, Gentoo 1.4
Posts: 400

Rep: Reputation: 30
Cups Printing Issue


From a terminal, I can execute the "lpr" command with a postscript file, and it will print with no issues. However, if I just attempt to print from a program (Mozilla, Firefox, Galeon, OpenOffice, etc) the print job aborts and nothing prints. A found one program that prints just fine (Gedit).

I'm not sure what's going on, but without telling FireFox to create a PostScript file then I manually print it via command line, I cannot print anything from FireFox. Any ideas?
 
Old 04-02-2005, 11:59 AM   #2
njk77
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
If you goto the CUPS web administration application (localhost:631) do you see the print jobs? Are there errors? In the mozilla/firefox print dialog under "properties" does it say lpr or just lp in the print command box? Any more info you could give would be helpful.
 
Old 04-02-2005, 12:13 PM   #3
Bigun
Member
 
Registered: Aug 2002
Location: Hickville, TN
Distribution: Gentoo > current. Have used: Red Hat 7.3, 9, Gentoo 1.4
Posts: 400

Original Poster
Rep: Reputation: 30
The machine having the issue is at home.

When I get home I'll post all the info I can.

But the FireFox print command is:

Code:
lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}
 
Old 04-03-2005, 12:16 PM   #4
Bigun
Member
 
Registered: Aug 2002
Location: Hickville, TN
Distribution: Gentoo > current. Have used: Red Hat 7.3, 9, Gentoo 1.4
Posts: 400

Original Poster
Rep: Reputation: 30
Okies.... when I print something, the admin page basically shows that a job was never sent.

Here's the output of my log:

Code:
I [03/Apr/2005:13:16:20 -0500] Listening to 0:631
D [03/Apr/2005:13:16:20 -0500] AddLocation: added location '/'
D [03/Apr/2005:13:16:20 -0500] DenyIP: / deny 00000000/00000000
D [03/Apr/2005:13:16:20 -0500] AllowIP: / allow 7f000001/ffffffff
D [03/Apr/2005:13:16:20 -0500] AddLocation: added location '/admin'
D [03/Apr/2005:13:16:20 -0500] DenyIP: /admin deny 00000000/00000000
D [03/Apr/2005:13:16:20 -0500] AllowIP: /admin allow 7f000001/ffffffff
I [03/Apr/2005:13:16:20 -0500] Loaded configuration file "/etc/cups/cupsd.conf"
I [03/Apr/2005:13:16:20 -0500] Configured for up to 100 clients.
I [03/Apr/2005:13:16:20 -0500] Allowing up to 100 client connections per host.
I [03/Apr/2005:13:16:20 -0500] Full reload is required.
D [03/Apr/2005:13:16:20 -0500] LoadAllPrinters: Loading printer SCX-4100...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "ipp"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "lpd"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "smb"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp0"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp1"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp2"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp3"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp4"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp5"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp6"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp7"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp8"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp9"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp10"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp11"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp12"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp13"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp14"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "usb:/dev/usb/lp15"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "http"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "scsi"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "parallel:/dev/lp0"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS0?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS1?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS2?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS3?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS4?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS5?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS6?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "serial:/dev/ttyS7?baud=115200"...
D [03/Apr/2005:13:16:20 -0500] LoadDevices: Added device "socket"...
I [03/Apr/2005:13:16:20 -0500] LoadPPDs: Read "/etc/cups/ppds.dat", 17 PPDs...
I [03/Apr/2005:13:16:20 -0500] LoadPPDs: No new or changed PPDs...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Scanning /var/spool/cups...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 2...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 3...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 4...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 5...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 6...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 7...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 8...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 9...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 10...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 11...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 12...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 13...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 14...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 15...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 16...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 17...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 18...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 19...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 21...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 22...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 24...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 25...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 26...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 27...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 28...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 29...
D [03/Apr/2005:13:16:20 -0500] LoadAllJobs: Loading attributes for job 30...
I [03/Apr/2005:13:16:20 -0500] Full reload complete.
D [03/Apr/2005:13:16:21 -0500] StartListening: NumListeners=1
D [03/Apr/2005:13:16:21 -0500] StartListening: address=00000000 port=631
D [03/Apr/2005:13:16:21 -0500] ResumeListening: setting input bits...
D [03/Apr/2005:13:16:26 -0500] AcceptClient: 5 from localhost:631.
D [03/Apr/2005:13:16:26 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:16:26 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:16:26 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:16:26 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:16:26 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:16:26 -0500] ProcessIPPRequest: 5 status_code=0
D [03/Apr/2005:13:16:26 -0500] CloseClient: 5
D [03/Apr/2005:13:16:26 -0500] AcceptClient: 5 from localhost:631.
D [03/Apr/2005:13:16:26 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:16:26 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:16:26 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:16:26 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:16:26 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:16:27 -0500] ProcessIPPRequest: 5 status_code=0
D [03/Apr/2005:13:16:27 -0500] CloseClient: 5
D [03/Apr/2005:13:18:27 -0500] AcceptClient: 5 from localhost:631.
D [03/Apr/2005:13:18:27 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:18:27 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:18:27 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:18:27 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:18:27 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:18:27 -0500] ProcessIPPRequest: 5 status_code=0
D [03/Apr/2005:13:18:27 -0500] CloseClient: 5
D [03/Apr/2005:13:18:29 -0500] AcceptClient: 5 from localhost:631.
D [03/Apr/2005:13:18:29 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:18:29 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:18:29 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:18:29 -0500] ProcessIPPRequest: 5 status_code=1
D [03/Apr/2005:13:18:29 -0500] ReadClient: 5 POST / HTTP/1.1
D [03/Apr/2005:13:18:29 -0500] ProcessIPPRequest: 5 status_code=0
D [03/Apr/2005:13:18:29 -0500] CloseClient: 5
I [03/Apr/2005:13:18:36 -0500] Scheduler shutting down normally.
D [03/Apr/2005:13:18:36 -0500] StopListening: closing all listen sockets.
D [03/Apr/2005:13:18:36 -0500] PauseListening: clearing input bits...
 
Old 04-03-2005, 01:17 PM   #5
njk77
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
Hmmm? Can you print a test page from the admin page in firefox?
 
Old 04-03-2005, 05:20 PM   #6
Bigun
Member
 
Registered: Aug 2002
Location: Hickville, TN
Distribution: Gentoo > current. Have used: Red Hat 7.3, 9, Gentoo 1.4
Posts: 400

Original Poster
Rep: Reputation: 30
Yup. No problems from the CUPS test page.
 
Old 04-03-2005, 05:46 PM   #7
njk77
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
I don't know what else to suggest without being there. Perhaps reinstall mozilla/firefox? Or install X-print? Does the printer even show up as an option when you try to print in mozilla/firefox? Can mozilla print a file (Postscript)? Wish I could be more helpful. CUPS can be a real pain sometimes!!! I'll keep looking around.
 
Old 04-04-2005, 05:53 AM   #8
Bigun
Member
 
Registered: Aug 2002
Location: Hickville, TN
Distribution: Gentoo > current. Have used: Red Hat 7.3, 9, Gentoo 1.4
Posts: 400

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by njk77
I don't know what else to suggest without being there. Perhaps reinstall mozilla/firefox? Or install X-print? Does the printer even show up as an option when you try to print in mozilla/firefox? Can mozilla print a file (Postscript)? Wish I could be more helpful. CUPS can be a real pain sometimes!!! I'll keep looking around.
Yeah, the printer shows up as an option. And like I said, attempting to print directly always fails. But if I print to a postscript file, then lpr the postscript file via terminal, I can print that way. Real Cooky.

There are a few other folks besides me having this issue. But it's at another forum, and posting it would mean death for this thread, but I can PM you some links if you'd like.

Last edited by Bigun; 04-04-2005 at 05:54 AM.
 
Old 04-05-2005, 05:32 PM   #9
Bigun
Member
 
Registered: Aug 2002
Location: Hickville, TN
Distribution: Gentoo > current. Have used: Red Hat 7.3, 9, Gentoo 1.4
Posts: 400

Original Poster
Rep: Reputation: 30
I give up! Unless I write a script to detect a PostScript file, then print and delete it, I see no other way!

How do I use X-print.... maybe that will work.... better yet, what is X-print before I go through the trouble..
 
Old 04-05-2005, 09:39 PM   #10
njk77
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
Sorry about your frustration. Wish I could do more. X-print is simply described as a printing system which allows X11 applications to use printers and such. It may already be installed. Seems like something CUPS would want to include as a suggested dependancy. In fact, looking over my dependancies, it is actually required to install an X-system on my system (Debian Sarge). I think you are on Gentoo, so it may not be the same depandancy. No guarantees though. I wouldn't want you to waste time installing if thats an issue, becuase I really don't know much about it. Good luck!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS issue with printing from Windows coreychch Linux - Software 1 10-19-2005 03:59 PM
Printing Problem (cups / cups-lpd) daleman Linux - Software 3 04-08-2005 08:01 AM
remote cups printing to a smb/cups print server? justanothergeek Linux - Networking 2 09-15-2004 08:31 AM
printing cups Ammad Linux - General 2 07-29-2004 11:54 AM
Slackware 9 and CUPS (CUPS=crap) - printing carboncopy Slackware 21 07-29-2003 03:27 PM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration