LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-26-2003, 11:11 PM   #1
darin3200
Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
CUPS installed in Gentoo but unable to access web admin tool


Hi,
I have gentoo installed and I have also gone ahead and ran emerge for cups. Whenever I open a browser, galeon or mozilla, and type
http://localhost:631
or
http://localhost:631/admin
or
127.0.0.1:631
I also get an error saying connection attempt refused. Any ideas on how to fix this?
Thanks,

UPDATE:
I checked and my port 631 is closed, do I have to have this open?

Last edited by darin3200; 12-26-2003 at 11:16 PM.
 
Old 12-26-2003, 11:17 PM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Is cupsd running? Try 'ps -e | grep cups'

If it's not running you can start it with 'cupsd' but you should check to see if Gentoo has a prettier startup script for it and that it will run on the next boot.
 
Old 12-26-2003, 11:22 PM   #3
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
You need to do "rc-update add cupsd default" and then run "/etc/init.d/cupsd start". That should start what you need.

Ian
 
Old 12-26-2003, 11:35 PM   #4
darin3200
Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Original Poster
Rep: Reputation: 45
I started cups and now it works, I will look into that startup script.
Thanks for all the help.
 
Old 12-26-2003, 11:57 PM   #5
darin3200
Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Original Poster
Rep: Reputation: 45
I can get cups going put when I go to install I get a client-error-not-possible, the same thing happens when I do it in the command line also.

root@gentoo darinf # /usr/sbin/lpadmin -p LaserJet -E -v parallel:/dev/lpr -m laserjet.ppd
lpadmin: add-printer (set device) failed: client-error-not-possible

anyone have any ideas on this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to access many web sites in core 3 JDA Fedora 3 03-02-2005 12:26 PM
OfficeJet G85, CUPS Web based Admin test print works, lpr/lp dose not. ptal-print OK. NLR Linux - Hardware 2 09-20-2004 03:59 PM
CUPS admin tool hangs coshx Linux - Software 0 09-11-2004 03:38 AM
CUPS - cannot access admin page Vincent_Vega Linux - Software 0 03-18-2004 02:20 AM
Unable to access to a website on apache web server bisbane Linux - Networking 3 07-11-2001 10:18 AM


All times are GMT -5. The time now is 09:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration