LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Cups Hostname Problem (http://www.linuxquestions.org/questions/linux-software-2/cups-hostname-problem-664037/)

xgme 08-20-2008 06:51 AM

Cups Hostname Problem
 
Hi there,
I share my printers with cups. I'm using linux-to-linux share.
On clients, if i introduce my server hostname and its ip in /etc/hosts everything is working. If I dont write clients cannot understand my server ip.
My problem is if there is any way to achieve this in another way. I want clients to recognize my server automatically. I should configure only server. Can I introduce my server to the clients with its ip?

Thanks for any help

xgme 08-21-2008 08:38 AM

Anyway I found the way and I do not have to introduce my printer server in clients' /etc/hosts anymore :)
It works wonderful!!!

theking2 06-06-2010 06:11 AM

why not tell us what you did or where you find the solution? It would greatly help this thread.

xgme 06-07-2010 04:01 AM

it was years ago, but as I remember I changed server-name for printer in Samba (not CUPS) to localhost. The problem was that servers are broadcasting themselves to clients via a machine name like "John's machine" and printer "John's printer" but clients search network hardware by their ip. Therefore, I could not establish an automatic recognition for clients.

I know setting server-name for printer to localhost is not a good way, because user may want to broadcast his printer with a specific name, but that time I could not find another solution.

In this configuration, there was some strange thing. When I set that configuration, client linux machines also automatically add that printer to their OS without any configuration or a command like "Add". Maybe this can be a security bug in linux machines because i can create a virtual machine and broadcast it as "localhost" and then i can automatically connect to clients in my LAN. It was the reason that i did not write the answer because this is really naive solution.


All times are GMT -5. The time now is 10:37 PM.