LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-14-2005, 04:46 PM   #1
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
Question Ctrl+Shift in text edit forms.


Hi there,

This has been bugging me for ages.

Whenever I edit text using Konqueror (eg text fields in web forms), KMail, and also various other KDE apps, I find that pressing Ctrl and Shift together produces some strange effects -- Press the right hand pair of ctrl+shift keys, and all the text jumps to the right of the form (ie mostly right justified, but the punctuation goes a bit weird), and the cursor changes; press the left hand pair, and it all jumps back to the left, but the odd cursor remains.

I have no idea why KDE does this, but I find it very irritating. It only happens in KDE apps; pretty much everything that shows a text edit field, except KWrite/Kate.

I'm using Suse 10.0, upgrated to KDE 3.5, but this has been happening before since Suse 9.1 and KDE 3.2. (and on several different computers, too)

However, on my spare computer, I can report that Mandrivia 2006/KDE 3.4 doesn't do it. Which leads me to guess it must be something specific to Suse?

It's very odd; I don't know what it's supposed to be for, but it's driving me nuts, so can anyone please tell me what this function is supposed to be doing, and why... and *PLEASE* how to turn it off!!

Thank you.
 
Old 12-14-2005, 09:35 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
i would say what you are seing is right Cntrl. Shift set to toggle between keyboard layouts
or just right alt is or right shift. That's how i do it right shift and the layout you are shifting to is right to left like hebrew or arabic or something
the prompt with the little flag on it is the right to left prompt.

in kde
Select Look & Feel -> Key Bindings
In Global Shortcuts pane,
In action - Current key list
Scroll down & select Keyboard -> Select next keyboard layout.
You can now assign a keyboard short cut by selecting Custom Key

should be able to undo it there or it's set in x using
xkbcomp
or
setxkbmap

you should be able to set it back also using setxkbmap

also these setting can be in your keyboard setting junk in xorg.conf or xfree86.conf or whatever it is.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+Shift Unicode input gone, after installing Japanese Input Methodes polemon Linux - Newbie 1 09-20-2005 05:17 PM
How do you press Ctrl,Alt and shift? littertiger Programming 4 05-17-2005 03:00 AM
KDE: Ctrl+shift = very annoying! Spudley Linux - Software 1 04-21-2005 05:11 PM
Combine text to forms image carstenson Linux - Software 0 12-15-2004 04:56 PM
How to change the keyboard layout with Ctrl + Shift? geraldomanaus Linux - Newbie 1 12-12-2002 02:49 PM


All times are GMT -5. The time now is 04:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration