LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   cross compilation (http://www.linuxquestions.org/questions/linux-software-2/cross-compilation-788867/)

shariefbe 02-13-2010 05:34 AM

cross compilation
 
I am trying to croos compile font-config-2.8.0. When compileing i got this error
Code:

  CC    fc-case.o
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
cc1: error: unrecognized command line option "-mfloat-abi=softfp"
cc1: error: unrecognized command line option "-mfpu=neon"
cc1: error: unrecognized command line option "-mfloat-abi=softfp"
cc1: error: unrecognized command line option "-mfpu=neon"
fc-case.c:1: error: bad value (armv7-a) for -march= switch
fc-case.c:1: error: bad value (cortex-a8) for -mtune= switch
make[3]: *** [fc-case.o] Error 1
make[3]: Leaving directory `/mnt/omap/sources/fontconfig-2.8.0/fc-case'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/mnt/omap/sources/fontconfig-2.8.0/fc-case'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/omap/sources/fontconfig-2.8.0'
make: *** [all] Error 2

I think it is using gcc instead of ARM toolchain. But in make file all are using ARM only. But how only this part can use GCC. I am not sure. if anybody knows the answer will be appretiated.

ForzaItalia2006 02-13-2010 08:35 AM

Yes, this seems to be "caused" by the use of gcc. But honestly, we should really get some fragments of your makefile to answer your question. From the error we can't really tell WHY you are using gcc instead of ARM toolchain. By the way, if your compiler is really gcc - which I am quite sure - you could verify the version by

# cc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.3.2-1ubuntu12' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu12)

- Andi -

shariefbe 02-13-2010 08:57 AM

you are give configuration for compile in host system. but i want to compile for target system (ie) ARM processor.
what can i do? see this is my makefile
http://www.filehosting.org/file/details/112202/Makefile
Please help me

knudfl 02-14-2010 08:14 AM

1 Attachment(s)
You can also show the output of : gcc-arm-linux -v

And may be your configure line, which may cause
some wrong options added to the Makefile.

Your Makefile can be attached to your post ..
using the "clip tool" in ' Post Reply '.

shariefbe 02-15-2010 12:36 AM

if i give that command i am getting as
Code:

sharief@sharief-desktop:/mnt/omap/sources/fontconfig-2.8.0$ gcc-arm-linux -v
bash: gcc-arm-linux: command not found
sharief@sharief-desktop:/mnt/omap/sources/fontconfig-2.8.0$

CC=arm-none-linux-gnueabi-gcc CXX=arm-none-linux-gnueabi-g++ LD=arm-none-linux-gnueabi-ld AS=arm-none-linux-gnueabi-as NM=arm-none-linux-gnueabi-nm AR=arm-none-linux-gnueabi-ar RANLIB=arm-none-linux-gnueabi-ranlib STRIP=arm-none-linux-gnueabi-strip OBJCOPY=arm-none-linux-gnueabi-objcopy OBJDUMP=arm-none-linux-gnueabi-objdump ./configure --prefix=$PREFIX --build=$HOST --with-arch=ARM --host=$TARGET --without-python --cache-file=cache-file
[/code]
This is the configure line which i use.

shariefbe 02-15-2010 06:23 AM

see the output of "cc -v"
Code:

sharief@sharief-desktop:/mnt/omap/sources/libtorrent-rasterbar-0.14.8$ cc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.3.3-5ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4)



All times are GMT -5. The time now is 11:29 AM.