LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-23-2005, 07:29 PM   #1
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Rep: Reputation: 30
CRITICAL: Some GUI apps run but do not show!


I have no idea how this problem occured today. The last thing I remember doing was upgrading some video codec library I think, and now suddenly some of my GUI apps are running, but they are not visible to me. I have since tried downgraded my Debian system, restarting X, trying a different WM, and re-installing offending apps, but to no prevail.

Two apps that I know are exhibiting this behavior right now are: xchat and synaptic.

When I run xchat (either from my FVWM menu or from console) I get the select server list just fine, but the main window doesn't appear! I know it is running though, because xchat is still listed as a running process after I close the select server list, and I can hear people say my name in the channels I have set to auto-join (a beep is emitted each time my name is said).


In the case of synaptic, I get the prompt to enter the root password ok, but after entering that the package window doesn't show! Once again, checking the process list synaptic is still running, but it's like it's invisible!!!


Does anyone have any clue at all what could be causing this? It's a very disrupting situation for me. This doesn't effect all of the apps (I can still open Firefox to post thank god), which makes it even more mysterious. Thanks for any advice.
 
Old 04-23-2005, 09:48 PM   #2
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Sarge is a developing distro. You may have problem like this when your packages are not upgraded and you add new s/w. New packages are tested against current packages, not older ones. Just my 2 cents.
 
Old 04-23-2005, 11:06 PM   #3
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
So you are just suggested I sit and wait for an upgrade to come along that will fix it then? Synatpic I can live without, but IRC is very important to me. Right now I'm using ircII to connect through the console, but it's so annoying. I can't see who's in the room, I can't be in more than one room and more than one server at once. Grrr. Maybe I'll try BitchX or another client and see if that works I guess.
 
Old 04-24-2005, 10:29 AM   #4
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
I had similar weird problems in the past. Unfortunately I do not remember details. But I remember the cause. The program or daemon I was upgrading was running, and its default behavior was to load conf into memory at startup and write it back to the file when exiting. Effectively overwriting new upgraded conf file, and at next startup it loaded old incompatible conf as a result (causing headache for me).

Here are rules I implemented for myself (for Sarge).
1. Always shut down the prog I upgrade. Especially X server.
2. Before installing something new upgrade existing packages.

Since then I have not experienced vague problems with my Sarge.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xhost + on ubuntu (to show remote x apps) tunasashimi Ubuntu 2 07-07-2005 07:18 AM
GUI clocks show UTC instead of localtime awu72 Linux - Newbie 2 05-09-2005 01:40 AM
GUI/window manager for debian mythTV to show off linux? case1984 Linux - General 2 03-08-2005 07:38 AM
I'm looking for some GUI apps.. VertX Linux - Newbie 3 02-08-2005 04:06 PM
Red Hat 8.0 problem? GUI won't show? THE RADICAL Red Hat 1 08-06-2004 01:51 PM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration