LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-04-2004, 07:24 PM   #1
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Rep: Reputation: 30
CPU temp warning after 2.6 kernel upgrade


I recently began booting on a new Debian packaged 2.6.7 kernel, Everything was fine except that my PC automatically restarted after 30 seconds ( ), but I fixed this by not loading the acpi kernel module (power management). Now I have a different problem:

Code:
Message from syslogd@localhost at Thu Aug  5 00:22:55 2004 ...
localhost kernel: CPU0: Temperature above threshold

Message from syslogd@localhost at Thu Aug  5 00:22:55 2004 ...
localhost kernel: CPU0: Running in modulated clock mode
This pops up very frequently (at an interval of about 15 seconds) on any command prompt I open up. I somehow doubt that my CPU temp is above the threshold, because I have a very nice Zalman CNPS7000-Cu cooling unit sitting ontop of my PIV, and I am usually not consuming more than 25% of the CPU clock cycles. I will note though that I'm in Phoenix and its pretty hot in my room, but this computer has survived in here for a year and I never had a CPU overheating problem back on my Windows monitoring software.


Anyone have an idea of what's wrong and how I can get rid of this annoying message? Thanks.
 
Old 08-04-2004, 11:11 PM   #2
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
Can't you edit the threshold value in syslogd conf files? If you really know the cpu is ok, raising this value will do no harm to it.
 
Old 08-05-2004, 12:03 AM   #3
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
If that's not it, you can raise the warning temperature in the BIOS, and see if that helps. What does cat /proc/acpi/thermal_zone/THRM/temperature say?
 
Old 08-05-2004, 01:36 AM   #4
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by LavaDevil94
If that's not it, you can raise the warning temperature in the BIOS, and see if that helps. What does cat /proc/acpi/thermal_zone/THRM/temperature say?
/proc/acpi doesn't even exist. Thanks for the tips though, I will try both and hope that they work.
 
Old 08-05-2004, 04:55 PM   #5
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
Well I went into my BIOS and didn't see any options for playing with CPU temperature settings. Although I did see that, according to my BIOS, my PIV 2.8Ghz CPU was running at 93C/199F. How the HECK can it be running that hot already when I just turned on the computer? I think something is amiss...
 
Old 08-05-2004, 06:12 PM   #6
phlyersphan
Member
 
Registered: Jun 2004
Location: Chicago, IL USA
Distribution: Mandrake 10
Posts: 103

Rep: Reputation: 15
Sorry to semi-hijack here, but what are you using to monitor your CPU temp? I've been looking for such a thing!
 
Old 08-05-2004, 06:26 PM   #7
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
ACPI can measure temperature. As for the original question, try turning on ACPI in the kernel, along with the Thermal Zone option.
 
Old 08-06-2004, 10:02 AM   #8
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
I can't. When I turn on ACPI on for my kernel (2.6.7), my computer automatically restarts itself after 30 seconds. If you have any clue how to fix this it would be most helpful.
 
Old 08-06-2004, 10:22 AM   #9
gmkrishn
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Rep: Reputation: 0
I have what hopefully is a similar problem. I have a dual boot machine (Windows and Debian Testing). Installed debian some time ago. According to my BIOS my CPU temp is 95C (Celcius) and it has been that way for about 2-3 years. So I disabled the CPU Temp warning in the BIOS (long time ago), and have never had a problem with it.

Couple of days ago, I appled the debian s/w updates (apt-get upgrade). Now every time I boot into debian, it automatically reboots after some specified time (may be a minute or two at best). Windows however has no problems, and has been working nice (this email comes from the windows side).

I tried passing "nomce" to the kernel but that did not help. After I read this thread I am going to try "acpi=off". In the long run, I dont want this to prevent me from using Debian (was working nicely till yesterday).

Any help will be appreciated. BTW I am using one of the 2.4.2x debian stock kernels (comes with debian)

- Murali
 
Old 08-06-2004, 10:44 AM   #10
gmkrishn
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Rep: Reputation: 0
I just checked. I am using 2.4.26-1-686 Debian Stock kernel. Passing acpi=off to the kernel (through lilo) did not help.
I am running out of ideas. I will get a Knoppix CD, so I can have some more time with the machine between reboots.
Also, "apt-get upgrade" did not complain about anything what so ever.

- Murali
 
Old 08-06-2004, 12:01 PM   #11
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
Well at least you can rule out that its not acpi which is causing the shutdown for your PC. I doubt it, but could it possibly be the other power module (I believe its called apm)? I don't know what else could be causing a forced system restart.
 
Old 08-06-2004, 12:25 PM   #12
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
R00ts, that's an idea, try disabling APM when enabling ACPI, If it still doesn't work, try using APM instead.
 
Old 08-06-2004, 01:21 PM   #13
gmkrishn
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Rep: Reputation: 0
In one of my numerous attempts. I booted with apci=off and as soon as I got a root shell, I did a "/etc/init.d/apmd stop". This was successful and about 5 seconds later it rebooted. I dont know this is equivalent to runing off apm. What are the option to turn off apm? I will try that together with "acpi=off". I have a feeling that the machine will still reboot.

If nothing else, I will have to re-install debian :-(

- Murali
 
Old 08-06-2004, 01:39 PM   #14
ghostwalker
Member
 
Registered: Jun 2003
Posts: 160

Rep: Reputation: 30
Did you apply any thermal grease to the processor when you applied the heat sink. If so, how long ago? You many need to reapply. Also are you overclocking your PC? If so back it off to the standard Ghz...

Walt
 
Old 08-06-2004, 01:50 PM   #15
gmkrishn
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Rep: Reputation: 0
I got the machine assembled. I have not applied any thermal grease since I got the machine (2-3 years ago).
I am not overclocking, running at regular speed (2.4 GHz). Can you point me to where I can learn more about thermal grease. Mainly, what to buy, and how to apply it.

- Murali

Quote:
Originally posted by ghostwalker
Did you apply any thermal grease to the processor when you applied the heat sink. If so, how long ago? You many need to reapply. Also are you overclocking your PC? If so back it off to the standard Ghz...

Walt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU kernel temp messages Crazy_lenny Linux - General 2 11-10-2004 01:30 AM
How to get the cpu temp? jon_k Linux - Software 1 10-26-2004 01:13 AM
CPU temp and a 2.6.x kernel Hangdog42 Slackware 3 11-01-2003 07:21 AM
cpu temp zaman Linux - Hardware 21 07-17-2003 10:21 AM
CPU Temp. moger Linux - Hardware 5 12-22-2002 07:25 PM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration