LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-09-2011, 01:15 PM   #1
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,051

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Could not start process Unable to create io-slave:klauncher said:Error loading kio-de


I'm using PCLinuxOS 2010 with kde4.5. Yesterday I installed kalarm using Synaptic. There were numerous updates required so I hesitated to do it but installed kalarm and tested it successfully. I have a list of the updates if that would be helpful. Today when I booted I saw the above error on the Desktop. No Desktop icons were shown. When I open Dolphin or Konqueror file managers no directories or files show and the above error is at the bottom of the window. The same error appears for all users. Logged in to GUI as root to test and had the same error.

All icons are available in the panel at the bottom of the Desktop and I can do pretty much anything except access files through the file managers.

Did some googling for the error and found this site:

http://forum.kde.org/viewtopic.php?f...ile%27#p169421

Checked and found that I did have the files:
/usr/lib/kde4/kio_file.so and /usr/share/kde4/services/file.protocol.

Tried the command suggested: kbuildsycoca4 --noincremental
This is the output:

Quote:
kbuildsycoca4 running...
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/sram_o.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/open_as_root.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/sram_r.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/sram_e.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/sram_d.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/xterm.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/bleachbit-root.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/google-earth.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/kde4/systemsettings.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/firefox.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/apt-sources-update.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(5830) parseLayoutNode: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file.
I found a post here at LQ with a similar error where it was suggested running kdeinit4 in a terminal which I tried. Got the last error from the above output. Not sure where to go from here. Any suggestions are welcome. Thanks in advance.
 
Old 08-09-2011, 07:53 PM   #2
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,051

Original Poster
Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
After having tried a number of possible solutions that failed, I found a site suggesting a complete upgrade. I had backups of all data I wanted so I opened Synaptic, clicked Mark All Upgrades, Apply and let it run. When it was finished, everything was working. It did update a lot of programs that I didn't necessarily want but that's insignificant.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to create io-slave: klauncher said: Error loading 'kio_file' albertkao Linux - Desktop 0 09-05-2010 11:59 PM
Unable to create i/o-slave - error loading 'kio_videodvd SkittleLinux18 Linux - Hardware 2 04-18-2008 05:12 AM
KDE Kio slave powadha Debian 12 04-27-2006 02:04 AM
Could not start process Can't talk to Klauncher t3gah Linux - Software 1 04-23-2005 09:41 PM
Help Klauncher said "Error loading 'kio_file' Avatar2U Linux - Newbie 3 01-06-2002 10:09 PM


All times are GMT -5. The time now is 06:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration