LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-19-2004, 06:54 PM   #1
KWTm
Member
 
Registered: Jan 2004
Distribution: Kubuntu 10.04 (Dell Linux-preinstalled laptop + a desktop); Maemo 5 (N900 phone computer)
Posts: 116

Rep: Reputation: 21
console is localized to Chinese --how do I turn it off ??


Just for kicks, I thought I'd set up my Mandrake 10.0 Official (KDE interface) with some alternate languages that I know, so I set up the languages in order of preference: English (American), English (GB), French, Esperanto, Chinese. (I installed Mandrake using English - American as the main language.)

Well, soon thereafter (but not immediately, which puzzles me), the console decided that I was Chinese-speaking and started using Chinese in everything. It's not the end of the world since I can read Chinese. But the headings for commands like "df" use Chinese characters for headings like "disk space remaining" etc., and even "mc", the Midnight Commander, has Chinese menu entries! This is especially a pain in the anus, since I can no longer jump to menu entries by typing the first letter of the entry (sorry, but the Chinese character "zuo3" isn't on my keyboard anywhere).

I tried setting the language order in the KDE Control Centre, to no avail. I even DELETED all the languages in the Control Centre except for English-US, with no effect.

I looked at the environment variables, and I saw:
Code:
LANG=zh_TW.UTF-8
LANGUAGE=zh_TW.Big5:zh_TW:zh_HK:zh
(The "zh" is for Chinese.) Well, it was set to Chinese, so I got rid of it with
LANG=""
LANGUAGE=""

(Someone tell me why there are two environment variables for language setting. Another case of Linux being a fragmented patchwork effort?)

Well, that didn't work either. While those two environment variables were blank, console still used Chinese. And any new console I start has the environment variables reverting to its Chinese settings.

HELP!! Where is the language set and what keeps changing my environment variables back to the Chinese settings?

(Edit: I found the following thread which describes a similar problem but does not identify a solution.)
http://www.linuxquestions.org/questi...guage+variable

Last edited by KWTm; 08-19-2004 at 06:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off beep in vitual console abrb220 Linux - General 4 02-22-2007 05:08 AM
Want to turn console access on/off for Linux netstv Linux - Software 1 12-23-2004 11:29 AM
what would you use for localized chat LinuxLala Linux - Software 0 08-29-2004 02:03 PM
LCD backlight does not turn off on console (acer travelmate 291LMi) zen_guerrilla Linux - Laptop and Netbook 0 07-16-2004 11:49 AM
display chinese in console skyevil Debian 1 09-12-2003 06:01 AM


All times are GMT -5. The time now is 07:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration