LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-15-2003, 01:54 AM   #1
dev8080
Member
 
Registered: Aug 2003
Posts: 64

Rep: Reputation: 15
Question conflict between real player and mplayer plugin


Real player plugin alone works fine for netscape but as soon as I install mplayer plugin for netscape, mplayer over writes real player and does not allow real player to open rm, ram files instead it itself tries to load rm and ram but is never able to do it. Though mplayer plugin is able to open other audio and video files.

Can anybody tell me how to allow real player plugin to handle rm and ram files instead of mplayer?

This is a strange situation and I am really confused.

Thanks
 
Old 09-15-2003, 10:24 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
i'd suggest letting mplayer handle real files. just recompile mplayer and point it to the location of the relaplayer binaries and it should then be able to play rm fine.
 
Old 09-15-2003, 12:12 PM   #3
dev8080
Member
 
Registered: Aug 2003
Posts: 64

Original Poster
Rep: Reputation: 15
Thanks for your suggestion, I would try installing it again. Also do I need to download all the codecs separately? Last time I had downloaded the all in one lite package. Also could you please let me know how do I point it to realplayer binaries, have to do it during compiling or after installing?

Thanks a lot
 
Old 09-15-2003, 12:18 PM   #4
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I believe by default myplayer looks for the codecs in /usr/lib/win32 so just download all the plugins from mplayers site and put them all in that directory.
 
Old 09-15-2003, 12:32 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
realplayer files won't be kept in the win32 directory. you might need to specify --with-reallibdir=/usr/lib/Realplayer9 or something when you compile it, but it will pick a few choice locations by default. you don't need anymore codecs, mplayer actually uses the executable file "sideways" to get what it wants.
 
Old 09-15-2003, 05:45 PM   #6
dev8080
Member
 
Registered: Aug 2003
Posts: 64

Original Poster
Rep: Reputation: 15
I recompiled with "./configure --enable-gui --with-reallibdir=/usr/lib/Realplayer8" and did "make" and "make install" But still mplayer is not able to play rm and ram files even from the terminal. Says unrecognized file format. I didnot uninstall my previous installation as I don't know how to uninstall source installation. So I guess this might have overwritten my previous installation as mplayer binary seems to be recently modified (shows today's date) Am I missing any thing?

Below is the out put of make install
====================================================
[root@localhost mplayer-1.0pre1]# make install
make[1]: Entering directory `/home/deva/Setup/mplayer/mplayer-1.0pre1/libdha'
mkdir -p /usr/local/lib
install -m 755 -s -p libdha.so.0.1 /usr/local/lib/libdha.so.0.1
rm -f /usr/local/lib/libdha.so
ln -sf libdha.so.0.1 /usr/local/lib/libdha.so.0
ldconfig
make[1]: ldconfig: Command not found
make[1]: *** [install] Error 127
make[1]: Leaving directory `/home/deva/Setup/mplayer/mplayer-1.0pre1/libdha'
make[1]: Entering directory `/home/deva/Setup/mplayer/mplayer-1.0pre1/vidix'
make[2]: Entering directory `/home/deva/Setup/mplayer/mplayer-1.0pre1/vidix/driv
ers'
mkdir -p /usr/local/lib/mplayer/vidix
install -m 755 -s -p *.so /usr/local/lib/mplayer/vidix
make[2]: Leaving directory `/home/deva/Setup/mplayer/mplayer-1.0pre1/vidix/drive
rs'
make[1]: Leaving directory `/home/deva/Setup/mplayer/mplayer-1.0pre1/vidix'
if test ! -d /usr/local/bin ; then mkdir -p /usr/local/bin ; fi
install -m 755 -s mplayer /usr/local/bin/mplayer
ln -sf mplayer /usr/local/bin/gmplayer
if test ! -d /usr/local/man/man1 ; then mkdir -p /usr/local/man/man1; fi
for i in en; do \
if test "$i" = en ; then \
install -c -m 644 DOCS/en/mplayer.1 /usr/local/man/man1/mplayer.
1 ; \
else \
mkdir -p /usr/local/man/$i/man1 ; \
install -c -m 644 DOCS/$i/mplayer.1 /usr/local/man/$i/man1/mplay
er.1 ; \
fi ; \
done
install -m 755 -s mencoder /usr/local/bin/mencoder
for i in en; do \
if test "$i" = en ; then \
ln -sf mplayer.1 /usr/local/man/man1/mencoder.1 ; \
else \
ln -sf mplayer.1 /usr/local/man/$i/man1/mencoder.1 ; \
fi ; \
done
*** Download skin(s) at http://www.mplayerhq.hu/homepage/dload.html
*** for GUI, and extract to /usr/local/share/mplayer/Skin/
 
Old 09-19-2003, 03:55 PM   #7
holgi26
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
I think i found the solution

I had the same problem but. I think i solved it.

i just downloaded the latest mplayer-plugin release and installed it.

i put the created mplayer-plugin.so into the mozilla/plugins directory and it worked. There was not longer a conflict. The real-streams are now opened with realplayer-plugin, quicktime with mplayer-plugin.
I think the maintainers now turned the support for realstreams off as standard.
You have to make sure that you can watch quicktime-movies with mplayer. If it doesn´t work there, the plugin won´t work either.

There is another file in the mplayer-plugin directory where you can configure which mediastreams mplayer-plugin should handle.
it is called mplayerplug-in.conf. You should copy this file into /etc. There you can configure it systemwide.

#debug=1
#logfile=$HOME/mpp.log
#vo=x11
#download=1
#dload-dir=$HOME/tmp
noembed=1
cachesize=6032
#use-mimetypes=1
#enable-real=1
#enable-wm=0
#enable-qt=0
#enable-mpeg=0

i activated noembed=1 (yes). Now i can watch quicktime-streams in fullscreen. Very nice . That even doesn´t work in windows as far as i remember. At least not with standard quicktime.

Furthermore it would be wise to set a cache. The size of depends on your internet connection or the resolution of the movie respectively.
ms-mediastreams doesn´t work yet. At least at my system.

Happy streaming
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
real player plugin on firefox/mozilla ksd Linux - Networking 3 03-28-2005 06:20 PM
MPlayer plugin & real media files. chrisknight Linux - Software 2 01-28-2005 08:55 AM
Real Player Plugin for Mozilla on Fedora Core 2 prashantha Linux - Software 2 10-02-2004 03:01 AM
Real Player Gold/Mplayer Conflict? webwolf70 Linux - Software 11 09-29-2004 10:15 AM
real player+ mplayer tsitras Debian 9 03-14-2004 05:03 AM


All times are GMT -5. The time now is 05:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration