LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-17-2011, 03:33 PM   #1
Skaperen
Senior Member
 
Registered: May 2009
Location: WV, USA
Distribution: Slackware, CentOS, Ubuntu, Fedora, Timesys, Linux From Scratch
Posts: 1,777
Blog Entries: 20

Rep: Reputation: 115Reputation: 115
configuring Xtightvnc/Xvnc/vncserver to listen via specific IP


The Xtightvnc server has an option called "-interface <address>" to specify what IP address to bind to its listen socket. However, that option only affects port 590X for the VNC side. It does not affect port 600X for the X side, which continues to bind to 0.0.0.0. Anyone know of a way to force this program to do BOTH listens on a specific IP address?
 
Old 10-19-2011, 10:14 PM   #2
hapihakr
LQ Newbie
 
Registered: Jul 2011
Location: San Antonio, TX, USA
Distribution: Linux Mint 9 Isadora LXDE
Posts: 8

Rep: Reputation: Disabled
You have to specify the correct parameters for the vncviewer:

vncviewer [options] [host][:display]
vncviewer [options] [host][:ort] <-- bracket colon colon p o r t bracket (ignore the smiley)
vncviewer [options] -listen [display]

The server options only control the server.

Last edited by hapihakr; 10-19-2011 at 10:17 PM.
 
Old 10-23-2011, 02:51 PM   #3
Skaperen
Senior Member
 
Registered: May 2009
Location: WV, USA
Distribution: Slackware, CentOS, Ubuntu, Fedora, Timesys, Linux From Scratch
Posts: 1,777
Blog Entries: 20

Original Poster
Rep: Reputation: 115Reputation: 115
Sorry, but I can see by using "netstat -antup" that Xtightvnc is listening wrong:

Code:
dirac/root /root 1# netstat -antup | fgrep vnc
tcp        0      0 172.30.60.1:5901        0.0.0.0:*               LISTEN      3245/Xtightvnc  
tcp        0      0 0.0.0.0:6001           0.0.0.0:*               LISTEN      3245/Xtightvnc  
dirac/root /root 2#
The highlighted 0.0.0.0 needs to be 127.0.0.1 so it will not accept connections from anywhere other than localhost. This is the server doing the wrong address binding. I need to know how to configure the server to do this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vncserver was working, now just gives black screen. Xvnc Free Edition 4.1.2 zushiba Linux - Server 6 10-02-2009 10:13 AM
How to get vncserver (Xvnc) and its apps to survive logout nicely???? [RHEL 5.1] rickhg12hs Red Hat 12 06-17-2009 04:54 PM
VNC listen specific interface Shwick Linux - Server 5 12-07-2008 06:16 PM
how to make vncserver listen on display 3 ashwin_cse Linux - Software 2 09-17-2007 11:46 PM


All times are GMT -5. The time now is 12:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration