LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Configuring Mutt , and gmail account? (http://www.linuxquestions.org/questions/linux-software-2/configuring-mutt-and-gmail-account-287995/)

D3javu 02-09-2005 03:01 AM

Configuring Mutt , and gmail account?
 
Hello buddy,
I'm a newbie and need some guide with Mutt. I don't know how to configure it , even worst , where to start ... i've installed it. I want to use it with gmail. I tried many muttrc on internet and even tried to configure my own muttrc but still no luck. fetchmail is install on my system... Please guide me , as i really want to learn. I also read the mannual on many websites .... spent few hours reading and try myself but i still cant successfully configure it. Thank you.

heema 02-09-2005 06:42 AM

dont worry it can be done ;)

i made it to work as i wanted my system to send me an emial when it finished a certain script

Here is how to make mutt send email using ur gmail account

1) Logon to ur gmail account , in settings -> Forwarding and POP
enable pop for all mail

2) Download nbSMTP (nbSMTP is a simple SMTP)
NOTE : u have to have openssl , libssl-dev installed

http://nbsmtp.ferdyx.org/

3) setup mutt by making a file named .muttrc in my HOME

here is mine :

set folder=~/Mail
folder-hook . "my_hdr From: <username@gmail.com>"
set sendmail="/usr/local/bin/nbsmtp -U username -P password -d gmail.com -h smtp.gmail.com -f username@gmail.com -p 587 -M p -S"

NOTE : ofcourse u have to enter ur username and password

Finally test it out by typing :

echo "It Works" | mutt -s "It Finally works" heematux@gmail.com


as for recieving here is a site i have found :

http://home.nyc.rr.com/computertaijutsu/mutt.html

D3javu 02-09-2005 09:07 AM

error
 
i search libssl-devel in yast2 , didnt found any so i leave it ...i've installed openssl-devel and all other i done as you said..i get this error when try to use make comannd on nbsmtp which configured with ./configure --enable-ssl ...

devanderan@linux:~/nbsmtp-0.98> make
make: Nothing to be done for `all'.



All times are GMT -5. The time now is 04:56 PM.