LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-31-2006, 10:59 PM   #1
itzig
Member
 
Registered: Jan 2006
Location: bay area
Distribution: slackware, Ubunutu, OSX
Posts: 77

Rep: Reputation: 15
./configure --prefix ??


Hi! I am trying to add a prefix to the ./configure line of gtkpod to help it find the libgpod-1.0.pc directory which is located @
/usr/local/lib/pkgconfig
I can't seem to make it work, probably because I am adding the wrong prefix, or flag?

error message during configure:
checking for PACKAGE_LIBS...
Package libgpod-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgpod-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgpod-1.0' found
configure: error: ***
`config.log':
configure:4073: $PKG_CONFIG --exists "gtk+-2.0 >= 2.4.0 gthread-2.0 >= 0.14.0 glib-2.0 > 2.4.0 libglade-2.0 >= 2.4.0 gmodule-2.0 libgpod-1.0 >= 0.3.0" >/dev/null 2>&1
configure:4076: $? = 1
configure:4086: result:

configure help:
Fine tuning of the installation directories:
--bindir=DIR user executables [EPREFIX/bin]
--sbindir=DIR system admin executables [EPREFIX/sbin]
--libexecdir=DIR program executables [EPREFIX/libexec]
--datadir=DIR read-only architecture-independent data [PREFIX/share]
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
--libdir=DIR object code libraries [EPREFIX/lib]
--includedir=DIR C header files [PREFIX/include]
--oldincludedir=DIR C header files for non-gcc [/usr/include]
--infodir=DIR info documentation [PREFIX/info]
--mandir=DIR man documentation [PREFIX/man]

Program names:
--program-prefix=PREFIX prepend PREFIX to installed program names
--program-suffix=SUFFIX append SUFFIX to installed program names
--program-transform-name=PROGRAM run sed PROGRAM on installed program names

System types:
--build=BUILD configure for building on BUILD [guessed]
--host=HOST cross-compile to build programs to run on HOST [BUILD]

Optional Features:
--disable-FEATURE do not include FEATURE (same as --enable-FEATURE=no)
--enable-FEATURE[=ARG] include FEATURE [ARG=yes]
--enable-maintainer-mode enable make rules and dependencies not useful
(and sometimes confusing) to the casual installer
--disable-dependency-tracking Speeds up one-time builds
--enable-dependency-tracking Do not reject slow dependency extractors

Some influential environment variables:
CC C compiler command
CFLAGS C compiler flags
LDFLAGS linker flags, e.g. -L<lib dir> if you have libraries in a
nonstandard directory <lib dir>
CPPFLAGS C/C++ preprocessor flags, e.g. -I<include dir> if you have
headers in a nonstandard directory <include dir>
PKG_CONFIG path to pkg-config utility
PACKAGE_CFLAGS
C compiler flags for PACKAGE, overriding pkg-config
PACKAGE_LIBS
linker flags for PACKAGE, overriding pkg-config
CPP C preprocessor
 
Old 01-31-2006, 11:31 PM   #2
sewer_monkey
Member
 
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 624

Rep: Reputation: 31
Lightbulb

Quote:
Originally Posted by itzig
Hi! I am trying to add a prefix to the ./configure line of gtkpod to help it find the libgpod-1.0.pc directory which is located @
/usr/local/lib/pkgconfig
I can't seem to make it work, probably because I am adding the wrong prefix, or flag?
Have you tried adding /usr/local/lib/pkgconfig to the PKG_CONFIG_PATH environment variable as the error message suggests?

Try the following:
Code:
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH && ./configure
assuming you're using bash...
 
Old 02-01-2006, 09:50 AM   #3
henryquinn
LQ Newbie
 
Registered: Jan 2006
Posts: 13

Rep: Reputation: 0
The --prefix option specifies where the software will be located after a make install.
You should either have a --with-lib option, or as the previous post states, update the PKG_CONFIG_PATH path.

Good luck!
 
Old 02-01-2006, 02:38 PM   #4
itzig
Member
 
Registered: Jan 2006
Location: bay area
Distribution: slackware, Ubunutu, OSX
Posts: 77

Original Poster
Rep: Reputation: 15
thanks! I tried
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH && ./configure
but, I get this message again:
Package libgpod-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgpod-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgpod-1.0' found

I can see in there! there is no "with" option in the configure help...
 
Old 02-01-2006, 03:23 PM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by itzig
thanks! I tried
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH && ./configure
but, I get this message again:
Package libgpod-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgpod-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgpod-1.0' found

I can see in there! there is no "with" option in the configure help...
--libdir=DIR object code libraries [EPREFIX/lib]
 
Old 02-02-2006, 04:29 AM   #6
henryquinn
LQ Newbie
 
Registered: Jan 2006
Posts: 13

Rep: Reputation: 0
The --libdir=DIR options specifies where the program libraries will be installed once compiled.
It seems that the libgpod-1.0 library is not on your system.
The linker searches in /usr/lib and /lib for libraries when linking a program and configure should
complain if it doesn't find the library in there.
Have a look in /usr/lib and maybe /lib - if you don't find the required library there you'll need
to get and install it.

Henry
 
Old 02-02-2006, 04:37 AM   #7
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try,
Code:
$export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
$./configure
 
Old 02-02-2006, 10:14 AM   #8
caspervn
Member
 
Registered: Jul 2005
Location: Vietnam
Distribution: Fedora Core 2
Posts: 55

Rep: Reputation: 15
Quote:
Originally Posted by itzig
Perhaps you should add the directory containing `libgpod-1.0.pc'
to the PKG_CONFIG_PATH environment variable
As far as I know, you should compile gpod (not install by rpm packet) to any directory (using --prefix). After, you go to this dir and find the .pc (find . -type f -name *.pc). And then, you just copy this file to /usr/lib/pkgconfig (default path for pkg-config search).

I usually do this way when get this error
 
Old 02-02-2006, 11:01 AM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by caspervn
As far as I know, you should compile gpod (not install by rpm packet) to any directory (using --prefix). After, you go to this dir and find the .pc (find . -type f -name *.pc). And then, you just copy this file to /usr/lib/pkgconfig (default path for pkg-config search).

I usually do this way when get this error
I think its better to add /usr/local/lib/pkgconfig to PKG_CONFIG_PATH so that ./configure looks for the required files in /usr/lib/pkgconfig and /usr/local/lib/pkgconfig.
 
Old 02-03-2006, 12:39 AM   #10
itzig
Member
 
Registered: Jan 2006
Location: bay area
Distribution: slackware, Ubunutu, OSX
Posts: 77

Original Poster
Rep: Reputation: 15
I looked in /usr/lib and /lib, no such file there. "libgpod-1.0.pc" still resides in /usr/local/lib/pkgconfig
Should I just move it elsewhere?

code gives this error:
$export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
-bash: PKG_CONFIG_PATH=:/usr/local/lib/pkgconfig: No such file or directory
--that is weird, this is the exact path!

Caspervn, are you sayin that if I install it to some other directory, I wouldn't get this error?
don't you think it would still look for that other library it complains about?

thanks for all the help!
 
Old 02-03-2006, 08:30 PM   #11
itzig
Member
 
Registered: Jan 2006
Location: bay area
Distribution: slackware, Ubunutu, OSX
Posts: 77

Original Poster
Rep: Reputation: 15
The correct command was:

CFLAGS="-I$HOME/Applications/libgpod-1.0.pc/include -L$/usr/local/lib/pkgconfig" ./configure


thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure --prefix= plan9 Slackware 5 01-03-2013 05:44 AM
a portable ./configure --prefix option spuzzzzzzz Linux - Software 2 07-27-2004 05:34 AM
./configure --prefix=/??? mykrob Linux - Newbie 7 06-24-2004 10:59 AM
kde prefix error when running ./configure hoopyfrood Linux - Software 1 04-25-2004 06:40 PM
prefix argument to ./configure luck___ Linux - Software 2 03-13-2004 03:22 AM


All times are GMT -5. The time now is 08:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration