-   Linux - Software (
-   -   configure: error: The xdg python module is required (pyxdg or python-xdg) (

Sargalus 03-23-2010 02:02 AM

configure: error: The xdg python module is required (pyxdg or python-xdg)
Ok, im trying to install avant window navigator, but when I try to run ./configure i get the following error message.

configure: error: The xdg python module is required (pyxdg or python-xdg)

I downloaded the latest pyxdg package from linuxpackages and installed it then reran ./configure and still have the same issues. any ideas?

I just downloaded the source from their website and installed it that way and ran the ./configure again. I did not get the pyxdg error again but I got the following

checking for AWN... configure: error: Package requirements (glib-2.0 >= 2.16.0 gthread-2.0 gobject-2.0 desktop-agnostic >= 0.3.9 gtk+-2.0 >= 2.12.0 gdk-2.0 >= 2.12.0 dbus-glib-1) were not met:

No package 'desktop-agnostic' found

does this mean I need to install gnome before I can install AWN?

knudfl 03-23-2010 06:30 AM

I guess, you can use some of the info in these notes about desktop-agnostic:

'desktop-agnostic' : please read the file docs/install.rst
No packages, no tar balls, please get the files with the bzr command :
bzr branch lp:libdesktop-agnostic

cd libdesktop-agnostic/

./waf configure --prefix=/usr --config-backends=gconf --vfs-backends=gio --desktop-entry-backends=glib
Required : 1) pygobject
Slack 13: disk 1 slackware/l/pygobject-2.16.1-i486-1.txz
(( ))

2) vala
> vala-0.7.10-i486-1as.txz

3) gobject-introspection
gobject-introspection-0.6.9/ : ./configure --prefix=/usr

4) gconf

su , ./waf install
cd /usr/lib/pkgconfig/
<editor> desktop-agnostic.pc
.. and edit the version to 0.3.9

The Avant Window Navigator also requires libgtop : / Slackbuilds,
and libwnck : 2.22.3

Sargalus 03-23-2010 01:12 PM

Ok, I don't have the bzr command I guess I will have to find the package for it and get it installed, im working on the rest of the advise you put up, thanks for the responde

knudfl 03-23-2010 03:20 PM

> bzr (2.0.3)


Sargalus 03-23-2010 05:46 PM

Ok this might be a stupid question, but I don't understand the point of, as from what I can tell it doesn't have slackware packages on the site it has a link for the source code, then a link for the file. so im kinda lost on what to really do here, am I suppost to build my own slackware packages via the files then install them or what?

Sargalus 03-24-2010 12:17 AM

correct me if im wrong, but is gtk, glib and all that crap all part of the gnome desktop, because Im trying to install gtk+2.18.* and it's erroring out too, I juust don't get it, it's one error after another, try to install one thing to fix one error and that gives you and error. I never remember slackware being this bad when trying to install stuff. Any clarrification would be great

knudfl 03-24-2010 05:04 AM

GTK, GLIB, etc. are not only for Gnome, but for a
hundred other applications. If you have Slackware 13,
the system version = 2.14.7 , will do fine.
Changing it : Don't do that. Will usually trash a lot
more, than you expect.

Buiding a "Slackbuild" package is an easy thing.
Find lots of HOWTO examples with Google ..

P.S. : The Avant Window Navigator is probably a Gnome only thing,
may work only on the Gnome Desktop.

knudfl 03-24-2010 07:34 AM

The above continues in another thread :


All times are GMT -5. The time now is 05:05 PM.