Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-02-2008, 10:55 AM   #46
LQ 5k Club
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled

If you're new to Slackware, and not sure what you will need, always do a full install.
Old 10-09-2008, 10:01 PM   #47
LQ Newbie
Registered: May 2005
Posts: 1

Rep: Reputation: 0
Originally Posted by wvragga View Post
Greetings All,

this had me tearing my hair out for a while.....

The solution for me was to create 2 missing symbolic links, I got the info from the GCC install howto.

My error was that linux/limits.h did not exist .

In the dir usr/include linux should be linked to /linux/include/linux in the kernel source dir, and asm should be linked to linux/include/asm also in kernel source dir.

My commands needed were:

ln -s /usr/src/linux/include/linux /usr/include/linux

ln -s /usr/src/linux/include/asm /usr/include/asm

This assumes that you have a symbolic link in usr/src (or wherever your source is) linux that links to /linux-2.6.whatever your kernel is ;-)

Configure was looking for these links, as soon as I created them I was all good!

Ragga ;-)
Thanks for your post, I also got the same error , my solution is :

ln -s /usr/src/kernels/2.6.25-14.fc9.x86_64/include/linux /usr/include/linux
Old 10-17-2008, 09:15 AM   #48
LQ Newbie
Registered: Jun 2008
Location: France (Paris area)
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
Well, thanks for your advice.
My first problem was that "slackbuilds" clean up after use, including the configure.log file and leave nothing to look at. So I got something else to compile, i.e. wine-1.1.6. This generated a config.log which produced a number of lines similar to those below :

configure:3759: $? = 1
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Wine"
| #define PACKAGE_TARNAME "wine"
| #define PACKAGE_VERSION "1.1.6"
| #define PACKAGE_STRING "Wine 1.1.6"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3753: gcc -E conftest.c
In file included from /usr/include/bits/posix1_lim.h:153,
from /usr/include/limits.h:145,
from /usr/lib/gcc/i486-slackware-linux/4.2.3/include/limits.h:1
from /usr/lib/gcc/i486-slackware-linux/4.2.3/include/syslimits.
from /usr/lib/gcc/i486-slackware-linux/4.2.3/include/limits.h:1
from conftest.c:9:
/usr/include/bits/local_lim.h:36:26: error: linux/limits.h: No such file or directory

I'm supposing a way out is to create a link concerning "limits.h" somewhere, but I'm not sure about this, what would you do?

Cheers & thanks, A
Old 04-25-2009, 07:30 AM   #49
LQ Newbie
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
Originally Posted by zip View Post
Thank you for posting this solution.
I had the same problem.
Who would have known that cc1 is cc1plus?
This is for Debian 3.1. ./configuration for a Graphire 4 graphics tablet.

asus:/usr/bin# ln -s /usr/lib/gcc/i486-linux-gnu/4.0.3/cc1 cc1plus

I had this same issue on Freebsd for months and it's now solved. If using Freebsd do:

ln -s /usr/libexec/cc1 /usr/bin/cc1plus and you should be fine.
Old 05-05-2010, 02:58 AM   #50
LQ Newbie
Registered: May 2010
Posts: 1

Rep: Reputation: 0

Originally Posted by stevenking66 View Post

Not sure if this you proiblem, but for the benefit of the world in general, you can get the same error message if you do not have the kernel-source installed. My clue was in the config.log:

configure:3620: result: /lib/cpp
configure:3644: /lib/cpp conftest.c
In file included from /usr/include/bits/posix1_lim.h:130,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i586-suse-linux/3.3.3/include/limits.h:122,
from /usr/lib/gcc-lib/i586-suse-linux/3.3.3/include/syslimits.h:7,
from /usr/lib/gcc-lib/i586-suse-linux/3.3.3/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory

Hope this is helpful to someone

configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
i get this when i install a program that i need help ??
Old 12-29-2011, 04:12 AM   #51
LQ Newbie
Registered: Dec 2011
Posts: 1

Rep: Reputation: Disabled
Possible problem

file was empty

I was able to solve problem by creating link
ln -s /usr/include/linux/limits.h /usr/include/limits.h
Old 04-11-2012, 10:59 AM   #52
LQ Newbie
Registered: Apr 2012
Posts: 1

Rep: Reputation: Disabled
Originally Posted by Tinkster View Post
Have another look

gcc = C compiler
g++ = C++ compiler ...

I'm almost certain that Mandreck comes
with more than one gcc option to install.

Yep. solved my problem
Old 05-31-2012, 10:27 AM   #53
LQ Newbie
Registered: May 2012
Posts: 1

Rep: Reputation: Disabled
Cool This guy knows what's up

Originally Posted by imanassypov View Post

You are missing the g++ package. Just do 'apt-get install g++'.
This will definitely get you going with your /.configure

This solved my issue. And, it's the easiest solution.
Old 03-10-2016, 02:17 AM   #54
LQ Newbie
Registered: Feb 2009
Location: Shropshire, UK
Distribution: DSL
Posts: 13

Rep: Reputation: 1
gcc v g++ thanks

Thanks, Tinkster, your explanation of gcc versus g++ helped me, too.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
error: C++ preprocessor "/lib/cpp" fails sanity check marek345 Linux - Software 4 11-06-2008 09:49 AM
ardour wont configure: configure: error: C preprocessor "/lib/cpp" fails sanity check disciple061 Linux - Software 4 01-22-2005 12:35 PM
configure: error: C++ preprocessor "/lib/cpp" fails sanity check HELP Ckesey Linux - Newbie 3 10-04-2004 01:58 PM
configure: error: C++ preprocessor "/lib/cpp" fails sanity check HELP Ckesey Linux - Software 0 10-04-2004 09:49 AM
configure: error: C++ preprocessor "/lib/cpp" fails sanity check raela Linux - Software 6 03-16-2004 05:59 PM

All times are GMT -5. The time now is 05:17 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration