LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-27-2004, 05:53 AM   #1
puk
LQ Newbie
 
Registered: Apr 2003
Posts: 19

Rep: Reputation: 0
Unhappy ./configure: arts is missing a lib


configuring arts-1.2.0 produces some failure

the configure-script is missing a lib. called zlib:

> Possibly configure picks up an outdated version
> installed by XFree86. Remove it from your system.

> Check your installation and look into config.log

Searching the web doesn't help.

But i found out that
zlib == libz
?!?

what can i do?

i want to install my slackware from source.

so i set up some packages by using the slackware 9.1 CD
and tried to install the proggys (like X and so on) from source.

steps i have made after setup slacky:
- installing a new kernel(patched) kernel-version 2.4.24
- checkinstall
- pkgconfig

next package should be KDE --> artsd needed


THX for help
 
Old 02-27-2004, 07:10 AM   #2
vsj
LQ Newbie
 
Registered: Jan 2004
Location: Midwest USA
Distribution: Debian stable
Posts: 22

Rep: Reputation: 15
Hi,

You can download zlib 1.1.4 here: http://linux.tucows.com/preview/8818.html

HTH
 
Old 02-29-2004, 11:11 AM   #3
puk
LQ Newbie
 
Registered: Apr 2003
Posts: 19

Original Poster
Rep: Reputation: 0
the solution:

i installed zlib with the argument

./configure --prefix=/usr


so i had to add the following line(s) to the /etc/ld.so.conf

/usr/lib


i also added /lib
to this file.

cya
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with arts-1.4.2 and libXext-6.4.3 configure Fluxxdog Linux - Software 3 09-02-2005 05:04 PM
KDE 3.4 current, missing aRts package? Seiken Slackware 5 04-02-2005 06:40 AM
ardour wont configure: configure: error: C preprocessor "/lib/cpp" fails sanity check disciple061 Linux - Software 4 01-22-2005 12:35 PM
Missing lib files! stonehurstX11 Mandriva 9 12-15-2003 04:09 PM
Missing lib mikedh Linux - General 2 04-25-2001 10:06 AM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration