LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-23-2008, 10:04 AM   #1
rfee
LQ Newbie
 
Registered: Feb 2004
Posts: 3

Rep: Reputation: 0
config.log shows failure in sanity check for wxGTK on Fedora platform


Hello
I have recently installed fedora core 9 on a new laptop. This is to replace a system running Fedora core 5. Since I am a software developer I had variety of tools/software installed and running on that platform. In addition I wrote applications using the older platform. I say all this because I am trying to explain that we are currently migrating to the newer releases but can't until we get existing tools/apps migrated to the newer release. Legacy issues keep us from grabbing the latest releases of all the tools. Anyway the last tool that I am struggling with is wxWidgets. The release that was used to develope our previous apps is wxGTK 2.8.0. I am currently trying to build and install but have had some compatability issues. Examination of the config.log seems to point to a compatability issue with the C++ compiler. Anyway maybe I am way off base but the issue I am concentrating on is the compiler. After two solid days of effort I am requesting some assistance with this issue. My guess is that I am missing something obvious. So any help, hints or suggestions on resolving the issue would be greatly appreciated.

from config.log
Quote:
configure:2898: gcc -c -g -O2 conftest.c >&5
conftest.c:2: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'me'
configure:2904: $? = 1
configure: failed program was:
| #ifndef __cplusplus
| choke me
| #endif


Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by gtk+ configure 2.8.0, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ../configure --enable-static

## --------- ##
## Platform. ##
## --------- ##

hostname = localhost.localdomain
uname -m = i686
uname -r = 2.6.26.5-45.fc9.i686
uname -s = Linux
uname -v = #1 SMP Sat Sep 20 03:45:00 EDT 2008

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/bin
PATH: /bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1611: checking for a BSD-compatible install
configure:1666: result: /usr/bin/install -c
configure:1677: checking whether build environment is sane
configure:1720: result: yes
configure:1753: checking for gawk
configure:1769: found /usr/bin/gawk
configure:1779: result: gawk
configure:1789: checking whether make sets $(MAKE)
configure:1809: result: yes
configure:2038: checking build system type
configure:2056: result: i686-pc-linux-gnu
configure:2064: checking host system type
configure:2078: result: i686-pc-linux-gnu
configure:2088: checking for native Win32
configure:2099: result: no
configure:2153: checking for gcc
configure:2169: found /usr/bin/gcc
configure:2179: result: gcc
configure:2423: checking for C compiler version
configure:2426: gcc --version </dev/null >&5
gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2429: $? = 0
configure:2431: gcc -v </dev/null >&5
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-cpu=generic --build=i386-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) 
configure:2434: $? = 0
configure:2436: gcc -V </dev/null >&5
gcc: '-V' option must have argument
configure:2439: $? = 1
configure:2462: checking for C compiler default output file name
configure:2465: gcc    conftest.c  >&5
configure:2468: $? = 0
configure:2514: result: a.out
configure:2519: checking whether the C compiler works
configure:2525: ./a.out
configure:2528: $? = 0
configure:2545: result: yes
configure:2552: checking whether we are cross compiling
configure:2554: result: no
configure:2557: checking for suffix of executables
configure:2559: gcc -o conftest    conftest.c  >&5
configure:2562: $? = 0
configure:2587: result: 
configure:2593: checking for suffix of object files
configure:2614: gcc -c   conftest.c >&5
configure:2617: $? = 0
configure:2639: result: o
configure:2643: checking whether we are using the GNU C compiler
configure:2667: gcc -c   conftest.c >&5
configure:2673: $? = 0
configure:2677: test -z 
			 || test ! -s conftest.err
configure:2680: $? = 0
configure:2683: test -s conftest.o
configure:2686: $? = 0
configure:2699: result: yes
configure:2705: checking whether gcc accepts -g
configure:2726: gcc -c -g  conftest.c >&5
configure:2732: $? = 0
configure:2736: test -z 
			 || test ! -s conftest.err
configure:2739: $? = 0
configure:2742: test -s conftest.o
configure:2745: $? = 0
configure:2756: result: yes
configure:2773: checking for gcc option to accept ANSI C
configure:2843: gcc  -c -g -O2  conftest.c >&5
configure:2849: $? = 0
configure:2853: test -z 
			 || test ! -s conftest.err
configure:2856: $? = 0
configure:2859: test -s conftest.o
configure:2862: $? = 0
configure:2880: result: none needed
configure:2898: gcc -c -g -O2  conftest.c >&5
conftest.c:2: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'me'
configure:2904: $? = 1
configure: failed program was:
| #ifndef __cplusplus
|   choke me
| #endif
configure:3048: checking for style of include used by make
configure:3076: result: GNU
configure:3104: checking dependency style of gcc
configure:3187: result: gcc3
configure:3293: checking for a sed that does not truncate output
configure:3347: result: /bin/sed
configure:3350: checking for egrep
configure:3360: result: grep -E
configure:3376: checking for ld used by gcc
configure:3443: result: /usr/bin/ld
configure:3452: checking if the linker (/usr/bin/ld) is GNU ld
configure:3467: result: yes
configure:3472: checking for /usr/bin/ld option to reload object files
configure:3479: result: -r
configure:3497: checking for BSD-compatible nm
configure:3539: result: /usr/bin/nm -B
configure:3543: checking whether ln -s works
configure:3547: result: yes
configure:3554: checking how to recognise dependent libraries
configure:3726: result: pass_all
configure:4182: checking how to run the C preprocessor
configure:4217: gcc -E  conftest.c
configure:4223: $? = 0
configure:4255: gcc -E  conftest.c
conftest.c:10:28: error: ac_nonexistent.h: No such file or directory
configure:4261: $? = 1
configure: failed program was:
| /* confdefs.h.  */
| 
| #define PACKAGE_NAME "gtk+"
| #define PACKAGE_TARNAME "gtk+"
| #define PACKAGE_VERSION "2.8.0"
| #define PACKAGE_STRING "gtk+ 2.8.0"
| #define PACKAGE_BUGREPORT "http://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B"
| #define GETTEXT_PACKAGE "gtk20"
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:4300: result: gcc -E
configure:4324: gcc -E  conftest.c
configure:4330: $? = 0
configure:4362: gcc -E  conftest.c
conftest.c:10:28: error: ac_nonexistent.h: No such file or directory
configure:4368: $? = 1
configure: failed program was:
| /* confdefs.h.  */
| 
| #define PACKAGE_NAME "gtk+"
| #define PACKAGE_TARNAME "gtk+"
| #define PACKAGE_VERSION "2.8.0"
| #define PACKAGE_STRING "gtk+ 2.8.0"
| #define PACKAGE_BUGREPORT "http://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B"
| #define GETTEXT_PACKAGE "gtk20"
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:4412: checking for ANSI C header files
configure:4437: gcc -c -g -O2  conftest.c >&5
configure:4443: $? = 0
configure:4447: test -z 
			 || test ! -s conftest.err
configure:4450: $? = 0
configure:4453: test -s conftest.o
configure:4456: $? = 0
configure:4545: gcc -o conftest -g -O2   conftest.c  >&5
conftest.c: In function 'main':
conftest.c:27: warning: incompatible implicit declaration of built-in function 'exit'
configure:4548: $? = 0
configure:4550: ./conftest
configure:4553: $? = 0
configure:4568: result: yes
configure:4592: checking for sys/types.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for sys/stat.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for stdlib.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for string.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for memory.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for strings.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for inttypes.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for stdint.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4592: checking for unistd.h
configure:4608: gcc -c -g -O2  conftest.c >&5
configure:4614: $? = 0
configure:4618: test -z 
			 || test ! -s conftest.err
configure:4621: $? = 0
configure:4624: test -s conftest.o
configure:4627: $? = 0
configure:4638: result: yes
configure:4664: checking dlfcn.h usability
configure:4676: gcc -c -g -O2  conftest.c >&5
configure:4682: $? = 0
configure:4686: test -z 
			 || test ! -s conftest.err
configure:4689: $? = 0
configure:4692: test -s conftest.o
configure:4695: $? = 0
configure:4705: result: yes
configure:4709: checking dlfcn.h presence
configure:4719: gcc -E  conftest.c
configure:4725: $? = 0
configure:4745: result: yes
configure:4780: checking for dlfcn.h
configure:4787: result: yes
configure:4852: checking for g++
configure:4868: found /usr/bin/g++
configure:4878: result: g++
configure:4894: checking for C++ compiler version
configure:4897: g++ --version </dev/null >&5
g++ (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:4900: $? = 0
configure:4902: g++ -v </dev/null >&5
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-cpu=generic --build=i386-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) 
configure:4905: $? = 0
configure:4907: g++ -V </dev/null >&5
g++: '-V' option must have argument
configure:4910: $? = 1
configure:4913: checking whether we are using the GNU C++ compiler
configure:4937: g++ -c   conftest.cc >&5
configure:4943: $? = 0
 
Old 10-25-2008, 12:24 AM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,901

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
Gcc 4.3.1 is VERY strict , and dose not tolerate "unconventional "code syntax
see the gcc site for more info on getting the code to conform to the "standards"
also make sure ALL and EVERY *.h file you need is listed
#include<(every one you need).h>
 
  


Reply

Tags
fedora 9, g++, wxgtk, wxwidgets


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I've installed wxbase & wxGTK, where is wx-config? ballack Linux - Software 9 01-19-2010 01:03 AM
Sanity Check DotHQ Linux - General 6 03-31-2006 09:24 PM
Could not find working OpenSSL library, please install or check config.log -newb ques botman Suse/Novell 4 10-19-2005 05:03 PM
./configure sanity check xushi Slackware 9 06-18-2005 04:47 PM


All times are GMT -5. The time now is 04:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration