LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Compiz has no window borders at login, does if started manually (http://www.linuxquestions.org/questions/linux-software-2/compiz-has-no-window-borders-at-login-does-if-started-manually-772445/)

Person_1873 11-30-2009 09:16 AM

Compiz has no window borders at login, does if started manually
 
i'm running gentoo with gnome installed as the WM, i've also installed compiz-fusion and it starts and works fine when i run "compiz-manager" but if i specify in the gconf-editor to start compiz in place of metacity i end up with no window borders and X appears to be controlling my window layout.

could someone please help me out as to how to make this work properly?

bret381 11-30-2009 11:39 AM

compiz itself is not a window manager. you need to have either metacity or emerald set as the window manager.

add /usr/bin/compiz-manager to your list of startup programs. This should load compiz and a wm when you login

Person_1873 11-30-2009 05:08 PM

thankyou for the reply, i had realized this but there were no real explanations as to how to set that up, could you please tell me what i need to put in my gconf config?

bret381 11-30-2009 08:31 PM

You shouldn't have to do anything to the gconf editor. change your settings from compiz back to metacity and leave that alone. Then all you should have to do is set compiz-manager to run at startup. This should set everything up. If you do not want it all to load at startup, the compiz fusion icon is another option.

Person_1873 12-01-2009 02:06 AM

how do i set it to run at startup? i've tried setting a .gtkrc file and a .bash_profile file but nether of those has made it work

Person_1873 12-02-2009 07:07 AM

never mind, i figured out that i needed to emerge gnome-control-center to be able to access the startup programs

bret381 12-02-2009 08:12 AM

glad you got it figured out.


All times are GMT -5. The time now is 02:24 PM.