LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Compiz Fusion Mozilla problem no titlebar (http://www.linuxquestions.org/questions/linux-software-2/compiz-fusion-mozilla-problem-%96-no-titlebar-597502/)

JerryP 11-06-2007 09:09 AM

Compiz Fusion Mozilla problem no titlebar
 
Everything is fine with Compiz Fusion except when I open Firefox or Thunderbird. When they open they are at the top left of the screen and have no titlebar. I have tried all different Window Decorators and various combinations of same but it doesn't fix it.
The only workaround I have for Firefox is to do F11 (full screen), click “restore” and it then has a titlebar and can be moved. Thunderbird doesn't have a a “full screen” option so this little trick doesn't work with it.
My distro of choice is PCLinuxOS. I could use some advice on this.

I later found out that the titlebar is there, it's just above the screen/desktop.

alberto13 11-07-2007 07:54 PM

One.. posible
 
well dont know if this helps or already tried, but in ubuntu something like that happens, with compiz fusion, no titlebar in applications, just added on compiz settings, Windows decorator in the command box the corresponding windows manager, in my case i add "emerald"
with default gnome use "gtk-window-decorator", or if you have kde "kde-window-decorator" these without quotes
one little screenshot for reference. ;)
http://img139.imageshack.us/img139/2...enshot2jp1.png

JerryP 11-08-2007 06:02 AM

Thanks Alberto,
I was to the point of ripping out compiz fusion, after reinstalling didn't fix it, but first decided to turn off everything except my cube. This gave me back my title bars and I have been turning things back on, a little at a time. So far I can't find out what happened that made the titlebar go off screen but "if it ain't broke ...".
There are two features though, that I had with Beryl, that I liked but I can't seem to get back.
1. When I would put my mouse pointer in the upper right corner of the monitor, all open windows would come to the front window as smaller windows. I could then click on that window and the desktop would spin right to it. I can't seem to find the setting for this.
2. Firefox and Thunderbird open in the upper left corner. I'd like them to open more to the center of the screen.
Jerry

alberto13 11-29-2007 04:53 PM

Quote:

Originally Posted by JerryP (Post 2951948)
Thanks Alberto,
I was to the point of ripping out compiz fusion, after reinstalling didn't fix it, but first decided to turn off everything except my cube. This gave me back my title bars and I have been turning things back on, a little at a time. So far I can't find out what happened that made the titlebar go off screen but "if it ain't broke ...".
There are two features though, that I had with Beryl, that I liked but I can't seem to get back.
1. When I would put my mouse pointer in the upper right corner of the monitor, all open windows would come to the front window as smaller windows. I could then click on that window and the desktop would spin right to it. I can't seem to find the setting for this.
2. Firefox and Thunderbird open in the upper left corner. I'd like them to open more to the center of the screen.
Jerry

Hi, sorry for the delay, i've been out because school and other things, the first feature its enabled selecting the Scale Plugin in advanced desktop effects settings, then Scale plugin, Actions Tab, initiate windows picker, then double clicking that item, and in this dialog, select the preferred screen edge.

Reference screenshoot:
http://img407.imageshack.us/img407/2...enshot4fp2.png

jiml8 11-30-2007 10:54 AM

It might be that they are not opening AT the top left of the screen, but slightly ABOVE the top left of the screen, so that the titlebar is off screen.

Not a problem with compiz. Just hold down the alt key, then click/drag the window using whatever portion of it you can click on. It'll move and if the titlebar is there it'll come onscreen.

molgyk 01-02-2008 10:25 AM

Might be a solution
 
This might help:
http://www.moleculargeek.net/blog/co...rkarounds.html

JerryP 01-02-2008 11:45 AM

That's excellent. I actually got used to the alt-click/drag when it happens and don't have "workarounds" enabled at all.
Maybe you can answer two questions;
1. What is <super> key? I thought it was the windows key on the keyboard but it doesn't do anything for me.
2. In the link you provided moleculargeek has an OS X Vista type taskbar. Is that part of Compiz-Fusion? I also use KDE and not Gnome desktop.
Thanks.

basik1231 03-05-2008 06:38 AM

Quote:

Originally Posted by JerryP (Post 3008672)
That's excellent. I actually got used to the alt-click/drag when it happens and don't have "workarounds" enabled at all.
Maybe you can answer two questions;
1. What is <super> key? I thought it was the windows key on the keyboard but it doesn't do anything for me.
2. In the link you provided moleculargeek has an OS X Vista type taskbar. Is that part of Compiz-Fusion? I also use KDE and not Gnome desktop.
Thanks.

Hey, I know this might be a little late, was just looking for a fix to a problem I was having with compiz and saw your post. If you're interested, that OS X type taskbar is a program called kiba-dock I believe.

JerryP 03-05-2008 01:36 PM

Not that late. Thanks. I fooled around with a few of these and got tired of them pretty quickly. On the other hand I have never tired of Compiz-fusion. I found the keyboard command for xorg.conf, Option "XkbOptions" "altwin:super_win" that enables the super-key so I can write with fire, have it snow and drip water on the desktop (useless but it impresses people). I still have to drag my windows back onto the visible desktop. That would be nice to handle but it's not a big problem. Thanks again.


All times are GMT -5. The time now is 02:54 AM.