LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-01-2008, 01:28 PM   #1
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Rep: Reputation: 30
Red face Compiz Fusion crashes whole system if started with KDE - openSUSE 10.3


Ok, here's the issue

After an update (can't remember which one), the whole X System freezes when Compiz tries to start at the same time as KDE.

I mean a whole freeze, i can't CTRL + ALT + BACKSPACE, or even switch to virtual console... the whole keyboard won't respond... don't ask about Magic SysRQ key, as the Macbook doesn't have one! LOL <-- a sarcastic laugh!

Compiz works fine if I let the system run for a few minutes, but if it starts with KDE, it freezes and does not resume (well, I waited 5 minutes)

Sadly, once Compiz runs, KDE will always try to start it with a new session, so this means i have to run the:

Code:
#chmod -x /usr/bin/compiz
oh, and I obviously chmod it back when I run it later

command before I log into KDE.

My system seems up-to-date.

oh, before I forget, here is my xorg.conf:

Code:
# /.../
# SaX generated X11 config file
# Created on: 2008-01-10T16:30:36+0000.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "dri"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "gb"
  Option       "XkbModel" "macintosh"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
        Identifier      "Mouse[1]"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "SHMConfig"             "true"
        Option          "LeftEdge"              "10"
        Option          "RightEdge"             "1200"
        Option          "TopEdge"               "10"
        Option          "BottomEdge"            "370"
        Option          "FingerLow"             "10"
        Option          "FingerHigh"            "20"
        Option          "MaxTapTime"            "180"
        Option          "MaxTapMove"            "220"
        Option          "SingleTapTimeout"      "100"
        Option          "MaxDoubleTapTime"      "180"
        Option          "LockedDrags"           "off"
        Option          "MinSpeed"              "1.10"
        Option          "MaxSpeed"              "1.30"
        Option          "AccelFactor"           "0.08"
        Option          "TapButton1"            "1"
        Option          "TapButton2"            "3"
        Option          "TapButton3"            "2"
        Option          "RTCornerButton"        "0"
        Option          "RBCornerButton"        "0"
        Option          "LTCornerButton"        "0"
        Option          "LBCornerButton"        "0"
        Option          "VertScrollDelta"       "20"
        Option          "HorizScrollDelta"      "50"
        Option          "HorizEdgeScroll"       "0"
        Option          "VertEdgeScroll"        "0"
        Option          "VertTwoFingerScroll"   "1"
        Option          "HorizTwoFingerScroll"  "1"
EndSection


Section "Monitor"
  DisplaySize  286 179
  HorizSync    30-62
  Identifier   "Monitor[0]"
  ModelName    "APPLE LCD MONITOR"
  Option       "DPMS"
  VendorName   "APP"
  VertRefresh  43-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
  Modeline 	"1280x800" 69.75 1280 1328 1360 1440 800 803 809 823 +HSync -Vsync
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x800" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x800" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x800" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x800" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "945 GM"
  BusID        "0:2:0"
  Driver       "i810"
#  Driver       "intel"
  Identifier   "Device[0]"
  Option      "XAANoOffscreenPixmaps" "true"
  Option      "DRI"     "true"
#  Option      "AccelMethod" "EXA" 
  Option       "monitor-LVDS" "Monitor[0]"
  Option       "SaXDualHSync" "31-48"
  Option       "SaXDualHead" ""
  Option       "SaXDualMode" "Clone"
  Option       "SaXDualMonitorModel" "1024X768@60HZ"
  Option       "SaXDualMonitorVendor" "--> VESA"
  Option       "SaXDualOrientation" "LeftOf"
  Option       "SaXDualResolution" "1024x768"
  Option       "SaXDualVSync" "50-60"
  Option       "SaXExternal" "Identifier&EXT+VertRefresh&50-60+HorizSync&31-48+PreferredMode&1024x768+VendorName&--> VESA+ModelName&1024X768@60HZ"
  VendorName   "Intel"
EndSection


Section "Monitor"
  HorizSync    31-48
  Identifier   "EXT"
  ModelName    "1024X768@60HZ"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> VESA"
  VertRefresh  50-60
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option      "AIGLX" "true"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
Please help.. this is driving me insane... and only fuels the "Linux is Crap" debate with my school mates! (sometimes it's hard to convince people when the whole thing freezes )

Last edited by Ian_Hawdon; 04-01-2008 at 01:29 PM. Reason: chmodding back
 
Old 04-07-2008, 09:02 AM   #2
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Original Poster
Rep: Reputation: 30
bump anyone?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz-fusion opensuse loose the title to each window kinnth Linux - Software 4 04-06-2008 10:57 AM
compiz-fusion works better in Gnome or Kde?? LinuxNewbie999 Linux - Newbie 2 02-27-2008 10:16 AM
KDE Pager applet trouble with opensuse 10.3 and compiz-fusion Melted UFO Linux - Software 2 11-13-2007 09:15 PM
Compiz Fusion on OpenSuse 10.3 AIGLX Intel arindom Linux - Software 3 10-24-2007 04:31 AM
ATI + Compiz Fusion + Suse 10.3 + KDE = not working trademarka Linux - Software 3 10-22-2007 09:54 AM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration