LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-11-2012, 09:45 AM   #1
Nick_C
Member
 
Registered: Jan 2012
Location: London, England, UK
Distribution: CentOS, Mageia, Debian, Fedora, openSUSE, Ubuntu
Posts: 230

Rep: Reputation: Disabled
Compiling virt-viewer - No package ‘gmodule-export-2.0’ found


I am trying to compile virt-viewer-0.4.2 on CentOS6, virt-manager and virtinst have both compiled and installed ok.

Quote:
Configure: error: Package requirements (gmodule-export-2.0 >= 2.12.0) were not met:
No package ‘gmodule-export-2.0’ found
Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non standard prefix.
Alternatively, you may set the environment variables GMODULE2_CFLAGS and GMODULE”_LIBS to avoid the need to call pkg-config
See the pkg-config man page for more details
This error message doesn't mean a lot to me, I cannot find any gmodule-export-2.0 package available to install.
 
Old 03-11-2012, 11:30 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
Quote:
No package ‘gmodule-export-2.0’ found
Means : No /usr/lib(64)/pkgconfig/gmodule-export-2.0.pc

It's a pkg-config "package configuration file" ( .pc ).

Provided by glib2-devel : # yum install glib2-devel

.
 
Old 03-12-2012, 08:04 AM   #3
Nick_C
Member
 
Registered: Jan 2012
Location: London, England, UK
Distribution: CentOS, Mageia, Debian, Fedora, openSUSE, Ubuntu
Posts: 230

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
Means : No /usr/lib(64)/pkgconfig/gmodule-export-2.0.pc

It's a pkg-config "package configuration file" ( .pc ).

Provided by glib2-devel : # yum install glib2-devel

.
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VM server KVM no X11 can you x foward to virt-viewer? Nemus Linux - Virtualization and Cloud 1 12-21-2011 05:45 AM
[SOLVED] Cannot connect to newly created vm's using virt-viewer DraughtGlobe Linux - Virtualization and Cloud 2 03-08-2011 02:02 PM
LXer: Virt-install&Virt-manager at Xen 4.0-rc8 (2.6.32.10 pvops) Dom0 on top Ubuntu K LXer Syndicated Linux News 0 03-26-2010 09:41 PM
Package dependencies issues; gmodule, gobjects, etc. NikToo Linux - Software 2 01-31-2006 02:30 AM
gmodule-no-export-2.0 not installed? Feminista Linux - Software 2 03-12-2005 07:06 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration