LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 06-16-2003, 04:12 PM   #1
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Rep: Reputation: 30
compiling qt with thread support


I already configured, made and installed qt. Now I'm trying to compile another binary and it errors like this: checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

I don't think I compiled qt with thread support. How would I go about removing the current binary and re-compiling it with thread support?
 
Old 07-03-2003, 12:07 PM   #2
mushkode
LQ Newbie
 
Registered: Jul 2003
Location: Canada
Distribution: Slackware 9.0
Posts: 1

Rep: Reputation: 0
Getting the same error when trying to compile some KDE apps based on a Slack9.0 install of qt-3.1.2. According to many things I've read, Qt3 compiles with -thread in by default, though it can't hurt to specify it.
If you're going to be removing it, you'd just remove your entire $QTDIR directory tree, and recompile with the -thread option passed to ./configure.
I'm not looking forward to having to do this, myself. libqt-mt is there, and I still get threading errors. Looks like I may have to remove the Slack package and compile from source.
Trying to compile from source with the Slack package in place throws errors about 10 minutes into the compile.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling thread.c kourage Programming 5 09-28-2005 07:39 AM
QT with thread support ?????? bullwinkle Linux - Software 0 09-22-2004 06:51 AM
Compiling in ACPI support on Compaq 2135CA (system crashes while compiling) Dag Linux - Laptop and Netbook 20 07-30-2004 07:56 PM
Qt Thread Support Problem zombyLINUX Linux - Software 4 03-30-2004 02:26 PM
compiling Qt with thread support? timberwolf Linux - Software 4 12-06-2003 04:15 PM


All times are GMT -5. The time now is 07:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration