LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-25-2004, 04:00 PM   #1
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Rep: Reputation: 30
Compiling KDE Problem


Ok I'm trying to compile KDE but when I try to compile kdebase it says at the end of the ./configure that it couldn't find libsmbclient for Samba 3.0. It says that it will use a wrapper if I don't have it. I had Samba 2.something (whatever Slackware 9.1 comes with) so I uninstalled that with pkgtool and downloaded the source for Samba 3.0.4 and complied that. That worked successfully. Then I try running the ./configure on kdebase again and I get the same error. Anyone know what's going on here?
 
Old 05-26-2004, 02:43 AM   #2
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
yay i got it fixed I found some website on google that gave me my answer. I need to run "./configure --with-extra-includes=/usr/local/samba/include --with-extra-libs=/usr/local/samba/lib" and it worked. Here's the website if anyone cares.

http://www.bauklimatik-dresden.de/pr...n/kde_cvs.html
 
Old 05-26-2004, 01:41 PM   #3
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
ok now im getting another errror when i try to make kdebase

Can't open perl script "/dcopidlng/kalyptus": No such file or directory
make[3]: *** [dcop.kidl] Error 1
make[3]: Leaving directory `/home/daniel/kdebase-3.2.2/konqueror/keditbookmarks'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/daniel/kdebase-3.2.2/konqueror'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/daniel/kdebase-3.2.2'
make: *** [all] Error 2
 
Old 05-26-2004, 01:51 PM   #4
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
Ok n/m i got it fixed again lol. I need to do "export KDECONFIG=kde-config". Someone seriously need to make a guide on how to do all this.
 
Old 05-26-2004, 02:16 PM   #5
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
noone does cos the problems vary from machine to machine.
 
Old 05-26-2004, 03:07 PM   #6
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Quote:
Originally posted by AFI_Flame
Ok n/m i got it fixed again lol. I need to do "export KDECONFIG=kde-config". Someone seriously need to make a guide on how to do all this.
why? this is Slackware NOT Gentoo..........all you really need to do is use pkgtool
Code:
installpkg whatever.tgz
why make things hard on yourself???
 
Old 05-26-2004, 07:39 PM   #7
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
Because there isn't a binary package availible for slackware 9.1. There is the one from Slackware-current but it requires Xfree86 4.4.0 to run and I really don't want the because I use the ATI proprietery drivers and they don't work on 4.4.0. Anyway I finally got KDE to load with arts, kdelibs, and kdebase Now time to install the rest of the packages
 
Old 05-26-2004, 07:41 PM   #8
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
Ooh yea i forgot to mention I already had KDE 3.1.4 going before I started. That's the one that came with Slackware 9.1. I was upgrading to KDE 3.2.2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem compiling kde and another program poboy975 Linux - Software 3 01-18-2005 12:41 AM
Compiling KDE 3.3 dyermaker_yamar Linux - Software 3 11-05-2004 01:08 PM
problem compiling kde using konstruct the_loser Linux - Software 4 04-26-2004 11:27 AM
Compiling KDE 3.2.1 galvedro Linux - Software 0 04-01-2004 04:29 AM
compiling kde. tiger7007 Linux - General 3 03-29-2004 03:20 AM


All times are GMT -5. The time now is 09:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration