LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-18-2003, 09:27 AM   #1
king_nothingzzz
Member
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Red Hat Enterprise Linux 4
Posts: 120

Rep: Reputation: 15
Unhappy compiling Glib


Hi ...
Considering the advice got on my previous post regarding gaim and proxy etc, i tried to install the latest version of gaim...
When i tried to compile......i got the following error message

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at **************

So i downloaded the source of Glib and installed it.....

After that i compiled gaim 0.67 again, ending up with the same error message agian....

I want to know if there is a specific directory or a specific way of compiling Glib and Gaim....

Thanks for your time and efforts

King Nothing
 
Old 08-18-2003, 09:31 AM   #2
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
After compiling glib, type this command in a terminal :
Code:
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
Hope that helps...
 
Old 08-18-2003, 07:40 PM   #3
king_nothingzzz
Member
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Red Hat Enterprise Linux 4
Posts: 120

Original Poster
Rep: Reputation: 15
Thumbs down

No it didnt work, still the same error while compiling Gaim...

I have the files of Glib in a directory called /home/user/rpm/glib-2.0.0

Thats where i run * ./configure * and *make* and *make install*

is this anyway affecting it??

Anyways thanks a lot

Hoping to get a reply soon

King Nothing
 
Old 08-19-2003, 12:21 AM   #4
king_nothingzzz
Member
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Red Hat Enterprise Linux 4
Posts: 120

Original Poster
Rep: Reputation: 15
Hi,

I did as said, but this is what i got...

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.0, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

what is the path for the var LD_CONFIG_PATH??

and how do i remove the old version og glib if required(2.0.0)

Please Help!!!


Regs


King NOthing
 
Old 08-19-2003, 02:58 AM   #5
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
A better solution to make GAIM work is to install the glib-devel package from your distro cd, and then set PKG_CONFIG_PATH to /usr/lib/pkgconfig

Anyway, if you want to compile glib from source, you need to remove the old rpm.
So, type this command in a terminal :
Code:
rpm -e --nodeps glib-2
HTH
hfawzy
 
Old 08-20-2003, 02:04 AM   #6
king_nothingzzz
Member
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Red Hat Enterprise Linux 4
Posts: 120

Original Poster
Rep: Reputation: 15
But i compiled it from the *source*, i didnt install it with *rpm*

if i try to remove it by * rpm -e *, it says glib-2.0.0 not installed

can u tell me how to uninstall it , if i have compiled frm the source....

Will just deleting the directory help??
 
Old 08-21-2003, 08:44 AM   #7
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 711

Rep: Reputation: 32
remember to put in etc/ld.so.conf
the path where you installed Glib
and run source ~/.profile
 
Old 08-21-2003, 11:41 AM   #8
JreL
LQ Newbie
 
Registered: Aug 2003
Location: Tracy, California
Posts: 17

Rep: Reputation: 0
Ok, i went to RPM remove package system. glib-2.2.1 doesnt even come up, so now im even more confused. GlibC comes up, is that the same thing?... I dont think it is so i didnt remove that one LoL, but anyways any more advice? How would i make it so this stuff stops making it think glib-2.2.1 one exist, and thus making this POS work

Last edited by JreL; 08-21-2003 at 11:54 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling gimp-2.3.2, having issues with glib shevegen Linux - Software 2 08-03-2005 08:19 AM
Compiling old glib version- doesn't work? hbbtstar Linux - Software 6 05-07-2005 01:33 AM
glib problem while compiling djabbot Linux - Software 13 03-08-2005 08:03 PM
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4 MadSkillzMan Linux - Newbie 3 07-10-2004 05:10 AM
glib + kernel2.6 compiling problem thar Linux - General 0 11-25-2003 03:33 PM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration