LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-28-2006, 03:53 AM   #1
keyF
Member
 
Registered: Jan 2006
Location: Moscow
Distribution: Debian, RHEL, FreeBSD, CentOS
Posts: 38

Rep: Reputation: 15
compiling apache 2.2.3 in minimal config [solved]


Hi, all!

I'm trying to compile apache 2.2.3 with minimal set of features which are needed for my site.
So, i downloaded sources, unpacked them and run configure:

Code:
./configure --prefix=/usr/local/apache2 --with-mpm=prefork
 --disable-U4-mapped --disable-maintainer-mode --disable-pie
 --disable-authn-file --disable-authn-dbm --disable-authn-anon
 --disable-authn-dbd --disable-authn-default --disable-authn-alias 
--disable-authz-host --disable-authz-groupfile --disable-authz-user 
--disable-authz-dbm --disable-authz-owner --disable-authnz-ldap 
--disable-authz-default --disable-auth-basic --disable-auth-digest 
--disable-isapi --disable-file-cache --disable-cache 
--disable-disk-cache --disable-mem-cache --disable-dbd 
--disable-bucketeer --disable-dumpio --disable-echo 
--disable-example --disable-case-filter --disable-case-filter-in 
--disable-ext-filter --disable-include  --disable-filter 
--disable-charset-lite --disable-charset-lite --disable-deflate 
--disable-ldap --enable-log-config --disable-log-forensic 
--disable-logio --disable-env --disable-mime-magic 
--disable-cern-meta --disable-expires --disable-headers 
--disable-ident --disable-usertrack --disable-unique-id 
--disable-setenvif --disable-version --disable-proxy 
--disable-proxy-connect --disable-proxy-ftp --disable-proxy-http 
--disable-proxy-ajp --disable-proxy-balancer --disable-ssl 
--disable-distcache --disable-optional-hook-export 
--disable-optional-hook-import --disable-optional-fn-import 
--disable-optional-fn-export --disable-static-support 
--disable-static-htpasswd --disable-static-htdigest 
--disable-static-rotatelogs --disable-static-logresolve 
--disable-static-htdbm --disable-static-ab 
--disable-static-checkgid --disable-http --enable-mime 
--disable-dav --disable-status --disable-autoindex --disable-asis 
--disable-info --disable-suexec --disable-cgid --disable-cgi 
--disable-cgi --disable-cgid --disable-dav-fs --disable-dav-lock 
--disable-vhost-alias --disable-negotiation --enable-dir 
--disable-imagemap --disable-actions --disable-speling 
--disable-userdir --enable-alias --disable-rewrite --disable-so 
--enable-http
and after this

Code:
make && make install
I recieve following error when i'm trying to run httpd (with standart config which is supplied with sources):

Quote:
Syntax error on line 114 of /usr/local/apache2/conf/httpd.conf:
Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration
Order directive is provided by module mod_access, but http://httpd.apache.org/docs/2.0/ru/mod/mod_access.html says that this module "Available only in versions prior to 2.1".
So how do I get Order directives working in my apache? any changes in configure string?

may be this will help:

Code:
~# # /usr/local/apache2/bin/httpd -l
Compiled in modules:
  core.c
  mod_log_config.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_dir.c
  mod_alias.c

Last edited by keyF; 09-29-2006 at 04:28 AM.
 
Old 09-29-2006, 01:50 AM   #2
keyF
Member
 
Registered: Jan 2006
Location: Moscow
Distribution: Debian, RHEL, FreeBSD, CentOS
Posts: 38

Original Poster
Rep: Reputation: 15
nobody knows? i cannot belive this..
 
Old 09-29-2006, 04:27 AM   #3
keyF
Member
 
Registered: Jan 2006
Location: Moscow
Distribution: Debian, RHEL, FreeBSD, CentOS
Posts: 38

Original Poster
Rep: Reputation: 15
it was --enable-authz-host switch for ./configure script.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
minimal hardware for mysql server + apache server legolin Linux - Hardware 4 03-18-2005 06:14 AM
Minimal linux with apache II_pretender_II Linux - Distributions 12 11-15-2004 07:56 AM
minimal Kernel config file for HP nx9000 aviel Linux - Laptop and Netbook 0 08-11-2004 06:29 AM
Minimal samba config suggestion please. carboncopy Slackware 2 08-03-2004 09:18 PM
Minimal Slackware + Apache + PHP + MYSQL 7s3an Slackware 5 03-24-2003 06:40 PM


All times are GMT -5. The time now is 07:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration