LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-05-2003, 12:39 PM   #1
jarin scott
Member
 
Registered: May 2003
Distribution: LFS 6.0
Posts: 67

Rep: Reputation: 15
compileing avidemux with MPEG support


I want to use avidemux to create videos that can be burned onto a (S)VCD but when I select save as mpeg I get a message sayind that it is not complied with mpeg support. Does this mean I need to compile mjpeg tools which for me runs the configure script but fails at make. If I need Mjpeg tools can I get a list af dependences and instructions on how to build it. Will post the error message if you want to see it.

Thanks,
Jarin Scott
 
Old 07-19-2003, 03:46 PM   #2
jarin scott
Member
 
Registered: May 2003
Distribution: LFS 6.0
Posts: 67

Original Poster
Rep: Reputation: 15
I'm still tring to figure this out. I reinstalled avidemux today and now it will play mp3 sound but I am still unable to encode the file as an mpeg for a (s)vcd. I downloaded rpm's of mjpegtools and ran it in package manager and it needed four files: libXxf86vm.so.1, libforms.so.89, libquicktime.so.0, ld.so.1. Libforms and lib quicktime I downloaded but when I typed the other two into rpmfind one of them was glibc and the other was xfree. I tried installling mjpeg form source and it said that "Avifile divx encoding support: false" and "Quicktime playback/recording: false". When I do a make the error seems to be caused by the following: "lav_io.c:86:Warning: 'Put_int4' defined but not used. I googled this got one site and it seened like the guy cd'ed to mpeg2enc and ran make and make install. I tried it and it made the binary file mpeg2enc. I recomplied avidemux and still I can't create a mpeg from avi(divx format).

p.s.
I have to type the error messages so they may not be the samebut they should be close enough to the orignals.

Jarin Scott
 
Old 12-08-2003, 03:10 PM   #3
JoeDuncan
Member
 
Registered: Aug 2003
Location: Ottawa
Distribution: Redhat 5.2, 6.0, 6.1, Mandrake 7.2, 8.0, 9.1, 9.2, 10.0, Gentoo, Debian 3.1r0
Posts: 224

Rep: Reputation: 30
Hrm... I had similar problems. You may just need to create a symlink in your /usr/lib directory. Check there for any variations on the required files that you are missing and then see if creating the needed file as a symlink to one of those works...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
k3B MPEG-4 support mlu Linux - Software 1 04-11-2005 01:28 AM
mp3 and mpeg support for fedora c3 joel b Fedora 4 02-25-2005 02:54 AM
restore kdemultimdiea mpeg support tessx Fedora 2 06-20-2004 04:15 AM
mpeg support for xmms??? rebelcan Linux - Distributions 4 06-26-2003 04:51 PM
Lost my mpeg support :( digital bots Linux - Newbie 0 03-26-2002 01:43 AM


All times are GMT -5. The time now is 12:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration