Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-28-2005, 06:55 PM   #1
LQ Newbie
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
compile errors.


Im currently using GenToo linux as my distribution and while trying to emerge fluxbox i receive this error in which im not sure how to fix. I have noticed of course theres a path that it shouldnt be pointing to via '/usr/lib/gcc-lib/i386-pc-linux-gnu' I only have /usr/lib/gcc-lib/i686-pc-linux-gnu' Any ideas? Thanks in advance!!!

i686-pc-linux-gnu-gcc -shared .libs/loader_jpeg.o -Wl,--rpath -Wl,/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src/lib/.libs -L/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src/lib /usr/lib/ /var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src/lib/.libs/ -march=pentium3 -Wl,-soname -Wl, -o .libs/
ar cru .libs/jpeg.a loader_jpeg.o
ranlib .libs/jpeg.a
/bin/sed: can't read /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/ No such file or directory
libtool: link: `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/' is not a valid libtool archive
make[4]: *** [] Error 1
make[4]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src/modules/loaders'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src/modules'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0'
make: *** [all-recursive-am] Error 2

!!! ERROR: media-libs/imlib2-1.2.0-r2 failed.
!!! Function enlightenment_die, Line 94, Exitcode 0
!!! emake failed
Old 11-28-2005, 07:17 PM   #2
Registered: Dec 2003
Location: Fresno
Distribution: Gentoo Ricer
Posts: 85

Rep: Reputation: 15
The instlallation of imlib2, a dependency, failed. I noticed that the version that errors out is less than that in Portage. Emerge sync and then try again.

Look here

and here

and possibly here
Old 11-28-2005, 10:11 PM   #3
LQ Newbie
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0

Well i tried what you said and emerge --sync portage but to no luck. I really doubt sync portage is the program here because the errors states its looking for a particular directory. And that directory doesnt exists. Any ideas?
Old 11-29-2005, 12:11 AM   #4
Registered: Dec 2003
Location: Fresno
Distribution: Gentoo Ricer
Posts: 85

Rep: Reputation: 15
Go to the gentoo forums and search for the error there first. I have been on it two years and have never had to ask a question because their discussions have led me in the right directions.


You're going to need to use the to correspond with your version of gcc and by the way, it's a file .

Last edited by number9; 11-29-2005 at 12:14 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
c++ compile errors using g++ ttumelty Programming 5 09-08-2005 01:58 PM
compile errors davidleroux1 Programming 4 05-10-2005 10:03 PM
C++ compile errors Palamides Programming 1 03-09-2005 06:28 AM
Ndiswrapper Compile Errors ne2007ber Linux - Software 1 01-09-2005 02:33 PM
Compile Errors userini Linux - Software 6 07-16-2003 08:22 AM

All times are GMT -5. The time now is 05:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration