LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-06-2012, 04:05 AM   #1
digche
LQ Newbie
 
Registered: Dec 2012
Location: India
Posts: 4

Rep: Reputation: Disabled
Compilation Error in V4l2-utils test.


Hi
I am trying to compile v4l2_utils for v4l2-compliance test, while compilation "autoconf configure.ac' I am getting following error.
I took the v4l2-utils component from http://git.linuxtv.org/v4l-utils.git git patch.
could any one please tell me solution for the following bugs.


configure.ac:43: error: possibly undefined macro: AM_INIT_AUTOMAKE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.ac:45: error: possibly undefined macro: AM_MAINTAINER_MODE
configure.ac:52: error: possibly undefined macro: AC_PROG_LIBTOOL
configure.ac:53: error: possibly undefined macro: AC_PROG_MKDIR_P
configure.ac:73: error: possibly undefined macro: AM_CONDITIONAL
configure.ac:137: error: possibly undefined macro: AM_GNU_GETTEXT_VERSION
configure.ac:138: error: possibly undefined macro: AM_GNU_GETTEXT
configure.ac:139: error: possibly undefined macro: AM_ICONV

Last edited by digche; 12-07-2012 at 01:27 AM.
 
Old 12-07-2012, 12:21 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,273

Rep: Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663
Welcome to LQ.

Please do not use colored text. Your duplicate post is unreadable. (Yellow.)
http://www.linuxquestions.org/questi...st-4175440214/
Please hit the 'Edit' button to change to black text.
LQ Rules http://www.linuxquestions.org/linux/rules.html
I.e. double posting is not allowed.

About v4l-utils errors :
1) You can get the bug free source code here
http://ftp.de.debian.org/debian/pool...8.orig.tar.bz2

2) Looks like you will have to install libtool, gettext(-devel), glibc-devel.
( And update automake ? )

Which OS are you using ?

.

Last edited by knudfl; 12-07-2012 at 12:27 AM.
 
1 members found this post helpful.
Old 12-08-2012, 01:39 AM   #3
digche
LQ Newbie
 
Registered: Dec 2012
Location: India
Posts: 4

Original Poster
Rep: Reputation: Disabled
Sorry for duplicate post, I will take care of this in future indeed.

I am using putty session on x86 platform.
libtool is already installed.
 
Old 12-08-2012, 05:11 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,273

Rep: Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663
OK, I did try a couple of the "v4l-utils-<dc959f7>.tar.bz2" from
http://git.linuxtv.org/v4l-utils.git yesterday,
.. and got similar errors.
One OS some "configure.ac:45: error: possibly undefined macro: A*" error.
Another OS, another error, but none as extensive as yours.

Did you try using the bug free source
'v4l-utils/v4l-utils_0.9.0~test8.orig.tar.bz2' ?


And : If you want more answers, the Linux OS must be specified,
like CentOS 6.3, Fedora 17, Ubuntu 12.04, etc. :
http://www.linuxquestions.org/linux/...Ask_a_Question
http://linuxsilo.net/docs/smart-questions_en.html

.

Last edited by knudfl; 12-08-2012 at 05:22 AM.
 
Old 12-19-2012, 04:27 AM   #5
digche
LQ Newbie
 
Registered: Dec 2012
Location: India
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hi

Thanks for your support, The patch 'v4l-utils/v4l-utils_0.9.0~test8.orig.tar.bz2' didn't work.
actually the problem was I didn't had autoconfig package.
now compilation is ok.
for Autoconfig one should have latest in-developement source code from git clone "git://git.sv.gnu.org/autoconf"

now run "autoconf configure.ac", it will generate a configure script then run the script which will creat makefile in every required folder of you source code.


Thanks
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compilation Error in V4l2-utils test. digche Linux - Newbie 1 12-07-2012 03:39 AM
alsa-utils compilation shariefbe Linux - Newbie 1 12-28-2009 06:16 AM
Error in cross-compiling bluez-utils mrmuds Linux - Wireless Networking 0 06-30-2009 06:49 AM
bluez-utils cross-compiling error cloudlast Linux - Embedded & Single-board computer 4 05-07-2009 04:37 AM
rpm test issue for CD compilation gmac63 Linux - Software 1 12-04-2007 10:37 AM


All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration