LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-07-2004, 01:38 PM   #1
C-monkey
LQ Newbie
 
Registered: Jun 2003
Location: Santa Clara Valley
Posts: 17

Rep: Reputation: 0
Unhappy Comiling from source - GLib error!


Greetings all!

I have run into a persistent problem when attempting to complile a program from source code. I have limited experience doing this, but I have tried this with several versions of gAIM and the result is always the same during the "./configure" process:

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

I know I have at least GLib v. 2.2.3 installed. This is very frustrating as the RPM version of the same application installs without issue. I had one successful compile from source code process work when I installed the latest GLib from www.gtk.org the first time I encountered the problem.

I am using SuSE 9.0 Personal with kernel 2.4.21-99-default reporting.

Anything one could provide is appreciated.

Thanks,

C-monkey
 
Old 03-07-2004, 04:02 PM   #2
GregLee
Member
 
Registered: Feb 2004
Location: Waimanalo, HI
Distribution: Slackware 10, Fedora 6
Posts: 308

Rep: Reputation: 30
Did you look in config.log? There should be a copy there of the test program. You can clip it out and try to compile and run it yourself, to track down the problem. All sorts of things can go wrong. Maybe an include file can't be found, a library isn't in the load library path, or the configure script might be in error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
First time Kernal comiling richessence Red Hat 2 06-21-2005 03:56 PM
pango configure problem with glib from source loco_g Linux - Software 1 01-06-2005 11:11 AM
Comiling gimp-print on RH9 gives error CatSC Linux - Hardware 1 01-20-2004 07:03 AM
Trouble installing glib 2.2.1 from source SocialEngineer Linux - Software 10 05-07-2003 09:02 PM


All times are GMT -5. The time now is 04:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration