LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-03-2012, 04:02 PM   #1
battler
LQ Newbie
 
Registered: Apr 2012
Posts: 23

Rep: Reputation: Disabled
Clonezilla Could not stat device /dev/sda


I try to install 24 computers at the same time with Linux 12.04 Desktop. PXE works but is on unicast basis and I need something quicker and spare my io. I found clonezilla eventhough I had to fix a few bugs (I guess because of 12.04) i got it to work. The client boots with pxe and I need to make a image of the client that can be distributed to all others. I've attached a screenshot with the error message. It states the following:
Code:
Selecting device [sda1] found!
Selecting device [sda2] found!
Selecting device [sda5] found!
Getting /dev/sda1 info
Getting /dev/sda2 info
Getting /dev/sda5 info
Checking the integrity of partition table in the disk /dev/sda...
The partition table in this disk is illegal/invalid: /dev/sda
It's not supported by parted. Parted is used in clonezilla to parse the filesystem in the partition table. This partition table is detected as WRONG by parted!
The error messages from parted are:
#####################
Error: Could not stat device /dev/sda - no such file or directory.
####################
Offcourse I've checked the partitions and they are indeed named sda1 and 2
20120503_150125.jpg.jpg
 
Old 05-04-2012, 03:46 AM   #2
battler
LQ Newbie
 
Registered: Apr 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
Some one asked me to post the following, hope it helps.

parted.jpg
 
Old 05-07-2012, 06:44 AM   #3
battler
LQ Newbie
 
Registered: Apr 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
Still no one? I've discoverd that via the live CD everything works perfect. I can make and restore the images. However via PXE I can neither make or restore the images.
The error message with a image made from live CD and restored via PXE is the following:
Quote:
sfdisk: Fatal error: cannot find /dev/sda
This is done by sfdisk --force /dev/sda < /home/partimag/2012-05-07-11-img2/sda-pt.sf
Failed to create a partition table on this disk: /dev/sda
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iscsi: which local device (/dev/sda, /dev/sdb) is used WITHOUT dmesg? knikkerr Linux - Software 3 08-13-2010 04:30 AM
Installing RIP LinuX on a USB drive - device name /dev/sdc becomes /dev/sda Mleahy Linux - Software 1 07-30-2008 08:57 PM
how the device will take the name as /dev/sda.../dev/sdb... ? sanjay2004 Linux - Software 1 05-27-2008 09:25 AM
/dev/sda is not a valid block device C++ Linux - Hardware 23 03-24-2008 10:07 AM
/dev/sda is not a valid block device !!help!! akjafry Linux - Newbie 3 10-09-2007 10:00 AM


All times are GMT -5. The time now is 04:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration