LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-02-2006, 04:51 PM   #1
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Rep: Reputation: 30
clock not keeping time


I have a laptop, Dell D600, running Suse 10 and the clock will not keep time. It keeps time fine as long as the computer is on but after it is shut off for a while the time gets pretty eratic. At first it seemed that the clock would gain time, it gain more time the longer the computer was shut down. No it seems to be losing time after the computer is shut down. If I boot into WinXP the time is fine (of course, it could be syncing with a time server, I'll have to disable the internet connection and try that again).

Any ideas what could be the cause of this? It is pretty recent. Thanks.

Todd
 
Old 03-02-2006, 05:01 PM   #2
Cottsay
Member
 
Registered: Feb 2004
Location: Chaska, MN
Distribution: Fedora
Posts: 195

Rep: Reputation: 31
I would look at your CMOS battery level...and yea that network time thing could be fixing your XP OS...you could set up NTP on the SUSE installation too...
 
Old 03-02-2006, 07:33 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
Traditionally, all POSIX machines have their
system time in UTC format.
UTC (Universal Time Coordinated) is the same as GMT (Greenwich Mean Time)
The more stupid OS's (mainly the Microsoft ones)
require their users to configure their machines for local time only
if windows is writing local data to your hardware clock and Linux is reading it as UTC then this could be your problem.
Linux i guess in duel boot with MS has to be set to local
posible edit /etc/sysconfig/clock and use UTC=0 for local
 
Old 03-02-2006, 08:28 PM   #4
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Original Poster
Rep: Reputation: 30
My system is reading local time, I tried UTC to see if that made a difference but it did not. I disabled the wireless in WinXP and restarted it a couple of hours later and the time was right, I then rebooted into Linux and the time was 5:59PM when it is actually 8:21PM. Yesterday the time was going too fast, now it is going too slow... Maybe I just have some pissed of penguins in here...
 
Old 03-02-2006, 11:31 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
well it seems like if it actually keeps time once it's running then the timezone must be set wrong
poke around in /etc

if its actually not keeping time once it's running
time can get all screwy in Linux for sure with certain systems.
what do you get when you type
dmesg | grep high-res

you can designate other high-res time sources
try clock=tsc as a boot option

Last edited by foo_bar_foo; 03-02-2006 at 11:33 PM.
 
Old 03-03-2006, 01:07 AM   #6
jayakrishnan
Member
 
Registered: Feb 2002
Location: India
Distribution: Slacky 12.1, XP
Posts: 991

Rep: Reputation: 30
Most probably your CMOS battery is down, u might have to change it, its a small circle shaped one
 
Old 03-03-2006, 05:29 AM   #7
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Original Poster
Rep: Reputation: 30
The result is:

Using pmtmr for high-res timesource

I was thinking that it was the CMOS battery also but if I leave the computer off all day and then boot into WinXP the time is correct even with the wireless NIC disabled in Win (that way it can't sync to a time server).

I am going to have to methodically test different scenarios as this is a bit weird. I'll leave it off all day today and when I get home boot into Win and see what happens with the time.

Thanks.
 
Old 03-03-2006, 03:27 PM   #8
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Original Poster
Rep: Reputation: 30
I had the laptop off for about 8 hours and then booted into Windows (with the wireless disabled so that the time could not be synced with a server) and the time was right. I then rebooted into Suse and the computer time was 8:35 AM while true time was 3:22 PM.

I checked the timezone and it is correct. But it is not like it is a five hour shift. It might be 5 hrs and 17 mins this time and 8 hrs and 43 mins next time.

Maybe penguins just don't care about time?

Todd
 
Old 03-16-2006, 04:54 AM   #9
marret
LQ Newbie
 
Registered: Sep 2005
Distribution: (Suse); Zenwalk
Posts: 8

Rep: Reputation: 0
I had a similar problem: after I switched on the time showed some more or less random time one or two days behind. This problem started after I had played around with the time zones and changed the date once manually.
I read in one of the LQ threads from last year that someone solved such a problem by deleting /etc/adjtime. I did that too and this also did the trick for me.

Last edited by marret; 03-16-2006 at 04:55 AM.
 
Old 03-18-2006, 08:05 PM   #10
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Original Poster
Rep: Reputation: 30
I did that and it worked. My computer is now keeping perfect time. Thanks

Todd
 
Old 03-22-2006, 02:32 AM   #11
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 183

Rep: Reputation: 30
What is the purpose of the /etc/adjtime file?i had one pc that was synchronizing with a ntp server,but the time was always out with exactly 7 hours.i assumed it had something to do with UTC,but when i checked my timezone everything was fine and UTC was disabled,but for some reason it still adjusted according to UTC?i deleted the /etc/adjtime file and everything seems fine now.when does that file get created and what role does it play??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 10:58 PM
hwclock on a laptop is not keeping time okmyx Suse/Novell 1 12-01-2004 09:42 PM
Keeping time set right shilo Slackware 8 11-26-2004 08:19 PM
Keeping my clock accurate with crontab jspaceman Slackware 7 02-27-2004 04:12 PM
Clock not keeping time Culbert Linux - Software 3 03-15-2003 07:15 PM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration