LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-14-2010, 05:42 AM   #1
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
Clock jumps hours ahead after boot.


When I shut down the machine everything is as it should be. Time set from the net, hwclock synced.

When I boot again, time is set several hours into the future. This is an additive process, when I don't set the correct time it drifts with every boot even days into the future (until boot is denied, because files are too far in the future).

I tried to get rid of that behaviour by doing

Code:
sntp -P no -r pool.ntp.org
hwclock --systohc
I renamed /etc/adjtime which looked like this:

Quote:
22292.201093 1289670517 0.000000
1289670480
UTC
Now it looks as follows:

Quote:
0.000000 1289733620 0.000000
1289733620
UTC
To no avail. What could cause that and how can I correct it?

Last edited by JZL240I-U; 11-16-2010 at 02:22 AM.
 
Old 11-14-2010, 06:07 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Toronto Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,778

Rep: Reputation: 415Reputation: 415Reputation: 415Reputation: 415Reputation: 415
I don't think the atomic clocks are wrong, so that leaves the local clock on your system. When was the last time you changed the cmos battery on the system board? That clock may be drifting if the battery is at or near end of life.
 
Old 11-14-2010, 06:12 AM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
hi

can you state what distro this happens on and is this dual booting with windows?

2) tinycore allows a bootcode to set the timezone ...but link I think wants your locale correctly set.

http://www.tinycorelinux.com/faq.html#timezone

there is also a bootcode of tz=UTC-N

its the reverse of what you think Germany is +

this sign reversal is better explained in the puppy link
http://www.murga-linux.com/puppy/viewtopic.php?p=12690

Maybe you might want to advise your exact timezone locale for someone to figure out your hwclock settting?
 
Old 11-14-2010, 07:55 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Original Poster
Rep: Reputation: Disabled
Thanks for your answers.

@camorri: The system is brand new (one month). And it is not drift, since the time is kept accurately during sessions. And it was more or less stable the first few weeks. I'd guess it is a software-thingy.

@aus9: It is OpenSuSE 11.3_64 with no windows(c) (R) at all (there is a FreeBSD installation on a hard disk I salvaged from my old machine, but I can't boot it here).

I suspect the time gets *beep* during shutdown, since the hardware clock is haywire right after a "shutdown -r now". It is also not always (but sometimes) a multiple hours offset (like from the wrong timezone) but an arbitrary interval including an odd number of minutes (and probably seconds, didn't check that).

I use the timezone of "Berlin, Europe" as set up during install and confirmed by KDE right now. (Time is aligned with UTC, see first post). I don't quite get what you are saying with "its the reverse of what you think Germany is +" -- its not politics, I'd guess .

As to your links -- umm, they pertain to puppy-specific things, but I use SuSE. And I used the hwclock-commands as shown in my first post in analogy to the second link...

Last edited by JZL240I-U; 11-14-2010 at 07:57 AM.
 
Old 11-14-2010, 08:09 AM   #5
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
Originally Posted by JZL240I-U View Post
it is not drift, since the time is kept accurately during sessions
That's based on the incorrect assumption that there is only one hardware clock. This LQ post has an overview of hardware clocks.
 
Old 11-14-2010, 08:20 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Original Poster
Rep: Reputation: Disabled
Quote:
No problem if you don't dual boot or you live in a UTC time zone without daylight saving.
And I don't do dual boot. IT is CET time now not anymore CEST.

If you scroll back to my first post (or should I write "complaint"? ) you'll notice, that I factored those different time keepings in by first getting the accurate time from the net and then sync'ing it with the hardware clock. And I disabled "ntp" during that, too.
 
Old 11-18-2010, 02:01 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Original Poster
Rep: Reputation: Disabled
The solution to the problem is described here:

http://www.linuxquestions.org/questi...utdown-844592/

For those in a hurry: I had a custom initrd not of my making, which lacked some ingredients. Read all about it in the linked thread .

P.S.: This is another (unsuccessful) branch of the topic:
http://www.linuxquestions.org/questi...reboot-844338/

P.P.S.: And this is how it began:
http://www.linuxquestions.org/questi...nstall-842262/

Last edited by JZL240I-U; 11-18-2010 at 02:24 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amd 64 Chip - SUSE - Clock Speeds Ahead notdku Linux - Software 1 08-18-2006 01:39 AM
Linux OS Clock/Timezone shows the clock off by 6 hours between OS's JBailey742 Linux - Software 9 04-06-2006 11:40 PM
Gnome 2.8/FC3 clock-applet calendar jumps ahead by five months or 4 years magicvash Linux - Software 1 11-30-2004 03:33 PM
After restart time jumps 7 hours mlbaker Linux - General 4 03-22-2003 11:19 AM
clock changes hours by it self jct842 General 2 09-04-2002 10:26 PM


All times are GMT -5. The time now is 02:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration