LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-15-2004, 10:32 PM   #1
king_nothingzzz
Member
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Red Hat Enterprise Linux 4
Posts: 120

Rep: Reputation: 15
Exclamation cli:rpm question


Hi

I have this problem from quite sometime. I have tried many things but in vain.

Here goes..

When i install a rpm package, i use rpm -Uvh xyz.rpm (i use U instead of i, coz both install anyways) and it gets installed properly (lets assume that there were no dependency failures)

When i want to remove a package, ie..when i try rpm -e --allmatches --nodeps xyz.rpm i get the following error
error: package xyz.rpm is not installed

Since it said that the package was not installed, i tried rpm -Uvh xyz.rpm, it says package already installed.

I tried with rpm -iv xyz.rpm, says package already installed.

I know that there is a fundamental problem in the way i use these commands, but i am not able to figure out what is wrong . I am not able to erase any package that i have installed.

When i use the '--force' option while installing, upgrading it works, as in, it gets installed

I appreciate any suggestion

Thanks

King Nothing
 
Old 01-16-2004, 01:28 AM   #2
ashamril
Member
 
Registered: Jan 2003
Location: cyberjaya
Distribution: rh mdk deb fed suse
Posts: 99

Rep: Reputation: 15
just rpm -e xyz
if u not sure try rpm -qa|grep xyz
 
Old 01-16-2004, 01:54 AM   #3
king_nothingzzz
Member
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Red Hat Enterprise Linux 4
Posts: 120

Original Poster
Rep: Reputation: 15
No use.

tried grep, returns nothing, but when i try to install the same package again, says package already installed

King Nothing
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp CLI question JimBass Linux - Newbie 2 08-23-2004 02:26 PM
simple CLI question about size of HD? Lleb_KCir Linux - General 4 06-10-2004 10:00 PM
Simple Newb Question: How do I check what version of Redhat is Installed from the CLI praefex Linux - General 1 01-27-2004 08:30 PM
rpm question talkinggoat Linux - Newbie 2 09-26-2003 12:45 PM
CLI question SSA Linux - Newbie 2 01-19-2002 08:23 PM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration