LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-17-2006, 06:34 PM   #1
chrisyc
LQ Newbie
 
Registered: May 2005
Location: scotland
Distribution: SuSE 10.1 - OSS
Posts: 17

Rep: Reputation: 0
chroot'ing gives a bash segmentation fault


Hello all
after buying a new pc and it hanging on the install of SuSE 10.1 i decided it was time to try gentoo, so i downloaded and burnt the amd64.2006.0 gentoo install cd and booted up
i have successfully formatted and prepared my disk, and got my network up and running, and the stage3-amd64 copied along with portage and the distfiles
However; when i come to chroot'ing into my "new linux environment" i get this error;

$livecd gentoo # chroot /mnt/gentoo/ /bin/bash
$Segmentation fault

and upon the dmesg command i get this in relation

$livecd gentoo # dmesg | grep segfault
$bash[11786]: segfault at 00000000487474c0 rip 00002aaaaaaac277 rsp 00007fffffdf0560 error 6
$sh[11787]: segfault at 00000000487474c0 rip 00002aaaaaaac277 rsp 00007fffff9bb7c0 error 6

as you can see i tried it also with /bin/sh.

It was suggested to me i may have been using the wrong architecture stage3, although this is impossible as i took the portage, distfiles and the stage3 all from the livecd from which i booted

Any help to this would be greatly apprechiated

Thanks in advance

Chris
 
Old 04-19-2006, 03:06 AM   #2
andygo
Member
 
Registered: May 2005
Location: Ukraine, Kiev
Distribution: Gentoo, Kubuntu
Posts: 112

Rep: Reputation: 15
try to redownload your stage
http://gentoo.mirrors.pair.com/relea...2006.0.tar.bz2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika Suse/Novell 2 12-02-2005 09:34 AM
Segmentation fault, WHY?? eXor Slackware 8 07-20-2005 01:55 PM
Why do i get a Segmentation fault laclac01 Programming 20 12-10-2004 09:33 AM
Segmentation fault when mounting from a bash script crc294 Linux - Hardware 3 06-25-2004 04:00 PM
Segmentation fault suriyamohan Linux - General 5 10-21-2003 01:37 AM


All times are GMT -5. The time now is 03:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration