LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-05-2011, 05:41 PM   #1
MichalKvacek
LQ Newbie
 
Registered: Dec 2009
Location: Czech republic
Distribution: Arch Linux
Posts: 24

Rep: Reputation: 1
Choppy YouTube videos


Hi everyone,
I have got a problem with youtube videos - they are very choppy. Strange is, that this problem appears only on youtube.com. When I want to watch youtube video anywhere else (e.g. on Facebook). everything runs smoothly.
[michal@arch-linux: ~]$ firefox
OpenOffice path before fixup is '/usr/lib/openoffice.org3'
OpenOffice path is '/usr/lib/openoffice.org3'
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
That's what I see when I enter any YouTube video.

System informations are below:
[michal@arch-linux: ~]$ uname -a
Linux arch-linux 2.6.37-ARCH #1 SMP PREEMPT Fri Feb 25 09:07:57 UTC 2011 i686 Intel(R) Pentium(R) D CPU 3.00GHz GenuineIntel GNU/Linux

[michal@arch-linux: ~]$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

[michal@arch-linux: ~]$ firefox --version
Mozilla Firefox 3.6.15, Copyright (c) 1998 - 2011 mozilla.org
flashplugin 10.2.152.27-2

[michal@arch-linux: ~]$ pacman -Q intel-dri
intel-dri 7.10.1-1

[michal@arch-linux: ~]$ pacman -Q mesa
mesa 7.10.1-1
Videos ran previously fine. They are broken after upgrading Firefox to version 3.6.15, thought. Or maybe after last system upgrade, here is the list of upgraded packages in last two days.

[2011-03-03 15:55] upgraded exiv2 (0.20-1 -> 0.21.1-1)
[2011-03-03 15:55] upgraded file (5.05-1 -> 5.05-2)
[2011-03-03 15:55] upgraded libgl (7.10.0.git20110215-1 -> 7.10.1-1)
[2011-03-03 15:55] upgraded intel-dri (7.10.0.git20110215-1 -> 7.10.1-1)
[2011-03-03 15:55] upgraded mkinitcpio (0.6.8-1 -> 0.6.8-2)
[2011-03-03 15:57] upgraded kernel26 (2.6.37.1-1 -> 2.6.37.2-1)
[2011-03-03 15:57] upgraded libgexiv2 (0.2.2-1 -> 0.3.0-1)
[2011-03-03 15:57] upgraded mesa (7.10.0.git20110215-1 -> 7.10.1-1)
[2011-03-03 15:57] upgraded xfce4-panel (4.8.1-1 -> 4.8.2-1)
[2011-03-03 15:57] upgraded orage (4.8.0-1 -> 4.8.1-1)
[2011-03-03 15:57] upgraded ppl (0.11-1 -> 0.11.2-1)
[2011-03-03 15:57] upgraded qt (4.7.1-3 -> 4.7.2-1)
[2011-03-03 15:57] upgraded shotwell (0.8.1-2 -> 0.8.1-3)
[2011-03-03 15:57] upgraded xvidcore (1.2.2-1 -> 1.3.0-1)
[2011-03-04 15:03] upgraded shadow (4.1.4.2-4 -> 4.1.4.3-1)
[2011-03-05 14:39] upgraded dhcpcd (5.2.10-1 -> 5.2.11-1)
[2011-03-05 14:39] upgraded libmpc (0.8.2-3 -> 0.9-1)
[2011-03-05 14:39] upgraded mplayer (32792-2 -> 32792-3)
[2011-03-05 14:39] upgraded ncurses (5.7-4 -> 5.8-1)
[2011-03-05 14:39] upgraded sudo (1.7.4.p6-1 -> 1.8.0-2)
Have you got any idea how to solve this problem? It also appears in Chromius as well as in Opera. In both browsers outputs are exactly the same.)

Thanks for any advice.
 
Old 03-05-2011, 08:42 PM   #2
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 697

Rep: Reputation: 93
I wonder if your ISP is limiting bandwidth to youtube.com. It seems odd
that other videos are good, but not ones from a single site.
 
Old 03-05-2011, 10:08 PM   #3
Novartum
Member
 
Registered: Feb 2011
Location: France
Distribution: Arch Linux
Posts: 32

Rep: Reputation: 4
The issue should be fixed by right clicking on a youtube video --> settings. Then uncheck the "Enable hardware acceleration" box. This seems to be an issue with youtube only and has been experienced by a lot of users in the arch community lately. Let me know if this resolves your issue (it did for me).

MichalKvacek - as an aside, make sure you also visit the arch forums regularly. Or at least search the forums when you come across an issue. This has been covered in a number of threads over past few days by people experiencing the same problem

Last edited by Novartum; 03-05-2011 at 10:21 PM.
 
Old 03-06-2011, 03:51 AM   #4
MichalKvacek
LQ Newbie
 
Registered: Dec 2009
Location: Czech republic
Distribution: Arch Linux
Posts: 24

Original Poster
Rep: Reputation: 1
I know, that somebody should been experienced with this issue. I saw threads only about falling down Firefox when entered on YouTube etc. Unfortunately, I have not found any thread which could solve this issue. That's why I am asking here.

And about Settings. I can't try it, because the item Settings is disabled (it's gray and non-clickable). I think the problem is something with libvdpau_nvidia.so, because when this appears (that this shared libraly is not available), the video is choppy and unwatchable.
Strange is, that I have no nVidia card. I have tried to copy this libraly from nvidia-utils, but it doesn't help. There was some problem with GLX thought (I'm not sure, but it doesn't solved it.)
 
Old 03-06-2011, 08:48 AM   #5
Novartum
Member
 
Registered: Feb 2011
Location: France
Distribution: Arch Linux
Posts: 32

Rep: Reputation: 4
It was disabled for me as well; try on hulu.com video. For me I was unable to uncheck the box when watching the video regular size. A user on arch irc channel found that if you make the video fullscreen, you are able to uncheck the "Enable hardware acceleration" box.
 
1 members found this post helpful.
Old 03-06-2011, 02:52 PM   #6
MichalKvacek
LQ Newbie
 
Registered: Dec 2009
Location: Czech republic
Distribution: Arch Linux
Posts: 24

Original Poster
Rep: Reputation: 1
Thank you, Novartum. Visiting hulu.com (even if I'm not from USA, so I could not be able to watch any video) and unchecking "Enable hardware acceleration" helped.

Thanks a lot .
 
Old 07-09-2014, 06:57 PM   #7
methadus
LQ Newbie
 
Registered: Jul 2014
Posts: 1

Rep: Reputation: Disabled
Cool How to fix the choppy full screen video with youtube in mint / ubuntu

sudo gedit /etc/apt/apt.conf.d/70debconf.

Then put this code,:
APT::Cache-Limit "100000000";
on that file and then save it.

Next type this code on your terminal
sudo apt-get clean && sudo apt-get update --fix-missing
and you won’t find apt cache limit again in the next time.

It worked for me!!!

I copied this from another forum and it absolutely ended my struggles with this problem. Up to trying this I had tried EVERYTHING else. Hope some of you see and try this before going through all the crap I went through.

Good luck!
 
  


Reply

Tags
choppy, videos, youtube


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Videos on Ubuntu are choppy (Youtube), help? morgothaod Linux - Newbie 3 09-29-2010 07:01 PM
Latest Ubuntu 9.10 update made videos choppy? brianpbarnes Linux - Software 3 05-07-2010 01:11 PM
Can't run youtube videos sunils1973 Debian 11 12-10-2008 05:06 AM
LXer: Youtube-dl - Download videos from Youtube in openSUSE LXer Syndicated Linux News 1 08-14-2008 08:10 AM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration