LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-07-2002, 11:44 PM   #1
twk
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora/RHEL
Posts: 152

Rep: Reputation: 31
chipmunk


I am trying to compile chipmunk circuit simulation/design's library(psys 1.56), and I keep getting this following error message (using gcc 2.95.3)


if [ ! -d ../../lib ] ; then mkdir ../../lib ; fi
gcc -O3 -I../include -I. -DCHIPLIB=\"`cd ../../lib; pwd`\" -c -o sysdevs.o sysdevs.c
In file included from /usr/include/math.h:63,
from ../include/p2c/p2c.h:98,
from sysdevs.c:26:
/usr/include/bits/mathcalls.h:125: parse error before `1'
In file included from /usr/include/math.h:350,
from ../include/p2c/p2c.h:98,
from sysdevs.c:26:
/usr/include/bits/mathinline.h:539: parse error before `1'
sysdevs.c: In function `sysclock':
sysdevs.c:55: storage size of `tz' isn't known
sysdevs.c: In function `systime':
sysdevs.c:102: storage size of `tz' isn't known
make: *** [sysdevs.o] Error 1


can anyone help me? thanks ............
 
Old 09-08-2002, 07:38 PM   #2
pbharris
Member
 
Registered: Apr 2001
Location: chicago, IL
Distribution: debian, redhat
Posts: 280

Rep: Reputation: 30
hello,
try adding a -lm to the gcc options. if that does not work you may need to edit this sysdevs.c file.
 
Old 09-09-2002, 11:05 PM   #3
twk
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora/RHEL
Posts: 152

Original Poster
Rep: Reputation: 31
thanks, I found a rpm which works, thanks anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
AC97 sound card -- mp3 plays too fast -- chipmunk effect guybrush3322 Linux - Hardware 2 03-13-2005 10:08 PM
Windows 2000, sound is chipmunk style exodist General 9 02-02-2005 10:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration