LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-21-2004, 10:11 PM   #1
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
Unhappy Chinese Input Programs????


does anyone know is there a good chinese input program for linux?
also, would it work with gaim?
 
Old 08-22-2004, 05:13 AM   #2
mathfeel
Member
 
Registered: Feb 2002
Distribution: Gentoo
Posts: 95

Rep: Reputation: 15
if it works with linux, it should work with gaim.

I use scim, 因为我用拼音。
 
Old 08-22-2004, 08:45 AM   #3
fangshi
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
I use fcitx.
 
Old 08-28-2004, 12:50 AM   #4
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Rep: Reputation: 30
Chinese support is not included in most distro?

Meaning need to download 3rd party?
 
Old 08-28-2004, 12:58 AM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by fangshi
I use fcitx.
I tried fcitx. It wouldn't work with OOo running Fluxbox, and
even though I hate KDE I booted it. Fcitx ran, but the first
character I tried was ni and it did not display the correct Hanzi.
The other choices it gave were incorrect Hanzi and some had
English letters. Typical open source software, IMO. So I booted
back into Windoze, where Chinese input works great.

When I booted back into Slack and Fluxbox, I didn't get my Slack
background, nor my Fluxbox menu. Seems the xmod whatever
changes I'd made for fcitx hosed Fluxbox.

So, just another piece of open source software which doesn't
work, whose instructions when followed to the letter messed up
something else. When I get a break in my work, I'll go fix my Flux
setup in Slack and remove fcitx...
 
Old 08-28-2004, 01:07 AM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by subaruwrx
Chinese support is not included in most distro?

Meaning need to download 3rd party?
Thanks for the reply. We're not trying to run a Chinese OS,
just input Chinese characters (Hanzi) while running an English OS.
For instance, in Windoze XP you install Chinese support when you
install the OS, and then all you need to do is press Alt + Shift at
any time in any program to input in another language. 你好

In Windoze this is done via an IME (Input Method Editor). Open
source doesn't seem to have caught up yet - supply and demand,
and since most Chinese (at least in China) use Windoze because it's
free here, and the software is written for it and works - this will probably
be something that doesn't get a lot of attention for *nix OSs.
 
Old 08-28-2004, 02:28 AM   #7
mking007
Member
 
Registered: Jul 2003
Location: China
Distribution: Red Hat, SuSE and Novell Linux Desktop
Posts: 96

Rep: Reputation: 15
fcitx支持拼音和五笔,Scim支持所有的输入方式(好像SuSE带的那个Scim不行)。
 
Old 08-28-2004, 02:30 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by mking007
fcitx支持拼音和五笔,Scim支持所有的输入方式(好像SuSE带的那个Scim不行)。
Your input displays as garbage except for fcitx and Scim...
can you input in English so we can understand you?

Can you see Hanzi in my last post? Ni hao

Last edited by Bruce Hill; 08-28-2004 at 02:33 AM.
 
Old 08-28-2004, 03:13 AM   #9
mking007
Member
 
Registered: Jul 2003
Location: China
Distribution: Red Hat, SuSE and Novell Linux Desktop
Posts: 96

Rep: Reputation: 15
Sorry, If u need chineseinput system i think u should understand chinese well. I use Suse 9.1pro+firefox and my post display well on my screen. I don't know why there are garbage on your screen, it could proved that u can't make u browser well support Chinese!

BTW: Wo Hen Qifeng!
 
Old 08-28-2004, 03:29 AM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by mking007
Sorry, If u need chineseinput system i think u should understand chinese well. I use Suse 9.1pro+firefox and my post display well on my screen. I don't know why there are garbage on your screen, it could proved that u can't make u browser well support Chinese!

BTW: Wo Hen Qifeng!
Sorry, if you offer advice I think you should understand computer well. I have no problem displaying or inputting Chinese in my Firefox browser, or any other browser, or any other program in Windoze. However, the same can not be said for Slackware or Mandrake or Debian...

And you didn't answer my question - can you read the Hanzi in my post #6? Or is it that Ni kan bu dong Yingwen?

Are you saying that you're very good at chess, mad, or just windy? ;-)
 
Old 08-28-2004, 03:38 AM   #11
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
looks like an encoding issue as setting my main browser, konqeror, to auto causes it to look like garbage. manually setting the encoding to chinese cause it to be displayed right ( i think ) as i see something like:

fcitsome_chinese_charactersscimmore_chinese_characters...

it looked like garbage in firefox for me also. it looks like the encoding information of your post isn't getting set somehow.

as far as chinaman's post, i did see the chinese characters, which i'm going to assume is correct.

Last edited by megaspaz; 08-28-2004 at 03:40 AM.
 
Old 08-28-2004, 03:39 AM   #12
mking007
Member
 
Registered: Jul 2003
Location: China
Distribution: Red Hat, SuSE and Novell Linux Desktop
Posts: 96

Rep: Reputation: 15
Quote:
Originally posted by Chinaman
I tried fcitx. It wouldn't work with OOo running Fluxbox, and
even though I hate KDE I booted it. Fcitx ran, but the first
character I tried was ni and it did not display the correct Hanzi.
maybe u haven't config fcitx with correct Chinese fonts. and if you want your OO input and displayer chinese correct you should install OO 1.1 or above.

Last edited by mking007; 08-28-2004 at 03:51 AM.
 
Old 08-28-2004, 03:49 AM   #13
mking007
Member
 
Registered: Jul 2003
Location: China
Distribution: Red Hat, SuSE and Novell Linux Desktop
Posts: 96

Rep: Reputation: 15
Quote:
Originally posted by megaspaz
looks like an encoding issue as setting my main browser, konqeror, to auto causes it to look like garbage. manually setting the encoding to chinese cause it to be displayed right ( i think ) as i see something like:

fcitsome_chinese_charactersscimmore_chinese_characters...

it looked like garbage in firefox for me also. it looks like the encoding information of your post isn't getting set somehow.

as far as chinaman's post, i did see the chinese characters, which i'm going to assume is correct.

to displayer chinese correctly by firefox or mozilla, u should set u brows's encodeing to GBK(if you font support GBK, i.e. simsum) or GB 2312(all chinese font support this).

Last edited by mking007; 08-28-2004 at 03:54 AM.
 
Old 08-28-2004, 05:30 AM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by megaspaz
looks like an encoding issue as setting my main browser, konqeror, to auto causes it to look like garbage. manually setting the encoding to chinese cause it to be displayed right ( i think ) as i see something like:

fcitsome_chinese_charactersscimmore_chinese_characters...

it looked like garbage in firefox for me also. it looks like the encoding information of your post isn't getting set somehow.

as far as chinaman's post, i did see the chinese characters, which i'm going to assume is correct.
Okay, thanks megaspaz for pointing me in the right direction concerning the browser. I thought my encoding was set, but it wasn't - I'd just added Chinese as a language.

To update the browser issue, I've tried the following: Firefart 0.9.3 and Internut Exploder 6.0 in Windoze eXperiment. In Slackware Linux 10.0 I've tried Ephiphany (does anyone use that piece of junk?), Galeon, Nutscrape, Mozilla, Firefart 0.9.1 and Konqueror. And the winners are:
Internut Exploder (great looking fonts) and Konqueror (crappy looking fonts) are the only browsers that display all the Chinese input correctly. All those browsers display the 2 characters I inputed on my machine, but only those 2 display all the Hanzi in this thread.

最近怎么样?

So, that's a browser specific problem (once you have the proper encoding set). Btw - the fonts look crappy in every program in Slackware and Mandrake on my system, and I have all the same fonts installed and selected as I do in Windoze - where Internut Exploder and Firefart display beautifully, as does everything else - but in all four of the Linux distros I've tried, fonts look horrible in every program. That's another issue. Please don't address it in this thread. Email me if you have an idea. I've read and tried everything on the ~www~

However, when tricky_linux started this thread, he wasn't talking about browser display issues. He asked, "is there a good chinese input program for linux?" Let's get it back on topic, please...
 
Old 08-29-2004, 02:51 AM   #15
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by mking007
maybe u haven't config fcitx with correct Chinese fonts. and if you want your OO input and displayer chinese correct you should install OO 1.1 or above.
Would you please check my setup? This is my .fcitx/config
Code:
mingdao@paul:~$ cat .fcitx/config
[程序]
#区域设置=zh_CN
显示字体=*
显示字体大小=18
是否使用AA字体=1

[输出]
数字后跟半角符号=1
Enter键行为=2
分号输入英文=1
大写字母输入英文=1
联想方式禁止穇页=1

[界面]
候选词个数=5
是否使用3D界面=2
是否自动隐藏输入条=1
主窗口隐藏模式=1
是否光标跟随=1
光标色=92 210 131
主窗口背景色=230 230 230
主窗口线条色=255 0 0
输入窗背景色=240 240 240
输入窗线条色=100 200 255
输入窗箭头色=255 150 255
输入窗用户输入色=0 0 255
输入窗提示色=255 0 0
输入窗序号色=200 0 0
输入窗第一个候选字色=0 150 100
#该颜色值只用于拼音中的用户自造词
输入窗用户词组色=0 0 255
输入窗提示编码色=100 100 255
#五笔、拼音的单字/系统词组均使用该颜色
输入窗其它文本色=0 0 0

#除了“中英文快速切换键”外,其它的热键均可设置为两个,中间用空格分隔
[热键]
打开/关闭输入法=CTRL_SPACE
#中英文快速切换键 可以设置为L_CTRL R_CTRL L_SHIFT R_SHIFT
中英文快速切换键=L_CTRL
GBK支持=CTRL_M
联想支持=CTRL_L
全半角=SHIFT_SPACE
中文标点=ALT_SPACE
上一页=- ,
下一页== .
第二三候选词选择键=SHIFT

[五笔]
五笔四键自动上屏=1
自动调整五笔顺序=0
提示词库中已有的词组=0
五笔精确匹配=0
提示五笔编码=1
使用Z输入拼音=1
Z模糊匹配=1
增加五笔词组=CTRL_8
调整五笔顺序=CTRL_6
删除五笔词组=CTRL_7

[二笔]
向前穇页=[
向后穇页=]

[拼音]
使用全拼=0
拼音自动组词=1
保存自动组词=0
增加拼音常用字=CTRL_8
删除拼音常用字=CTRL_7
删除拼音用户词组=CTRL_DELETE
#重码调整方式说明:0-->不调整  1-->快速调整  2-->按频率调整
拼音单字重码调整方式=2
拼音词组重码调整方式=1
拼音常用词重码调整方式=0
是否模糊an和ang=0
是否模糊en和eng=0
是否模糊ian和iang=0
是否模糊in和ing=0
是否模糊ou和u=0
是否模糊uan和uang=0
是否模糊c和ch=0
是否模糊f和h=0
是否模糊l和n=0
是否模糊s和sh=0
是否模糊z和zh=0
mingdao@paul:~$
I'm using OO 1.1.2. I've posted a screenshot of an OOo window when I try to use fcitx.
Maybe you can tell me what the problem is...the screenshot is here ->
https://www.cotse.net/users/servants...x_screenie.png

When I type ni in Pinyin it gives me some funny choices, as you can see on the screenshot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinese input djib Debian 20 06-16-2008 01:41 AM
Chinese input denning Slackware 16 02-24-2005 12:39 AM
Chinese input Cyberian Fedora 2 02-15-2005 06:32 AM
Chinese Input Problems hegel Linux - Software 1 09-26-2003 04:31 PM
Chinese Input system awtoc123 Linux - General 2 05-27-2003 08:18 PM


All times are GMT -5. The time now is 07:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration