LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-28-2003, 10:11 AM   #1
cblau
LQ Newbie
 
Registered: Feb 2003
Location: Valencian Nation (Next to Spain)
Distribution: SlackWare 8.1
Posts: 1

Rep: Reputation: 0
Unhappy checking for Qt... configure: error: Qt >= 1.42 (libraries) not found.


I've got installed SlackWare 8.1 with Qt 3.0.4 as it comes in full instalation on CD.

When I want compile anything that checks for qt i've got these error:
checking for Qt... configure: error: Qt >= 1.42 (libraries) not found. Please check your installation!

How can i solve it?
Thanks
 
Old 02-28-2003, 10:23 AM   #2
kater
Member
 
Registered: Feb 2003
Location: Switzerland, Berne
Distribution: Slackware 9.0
Posts: 186

Rep: Reputation: 30
Edit your QT_PATH.
 
Old 02-28-2003, 05:11 PM   #3
crichards
Member
 
Registered: Feb 2003
Location: Arizona
Distribution: Gentoo!
Posts: 124

Rep: Reputation: 15
Set the variable QTDIR to the directory you want Qt to install to.
 
Old 02-28-2003, 05:23 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
it's probably not a path issue at all, you just don't have the qt-devel pacakge installed. I don't honestly know if qt1 is compatable with qt3 either (i avoid qt apps whnever possible) so you might need to install the old original qt libraries aswell.
 
Old 02-28-2003, 07:11 PM   #5
kater
Member
 
Registered: Feb 2003
Location: Switzerland, Berne
Distribution: Slackware 9.0
Posts: 186

Rep: Reputation: 30
No, Qt is not backward-compatible.
 
Old 02-28-2003, 08:19 PM   #6
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
You need to get a qt3 version of the application your trying to install.
 
Old 02-28-2003, 09:34 PM   #7
crichards
Member
 
Registered: Feb 2003
Location: Arizona
Distribution: Gentoo!
Posts: 124

Rep: Reputation: 15
Hmm...Never noticed that. Sorry for misleading you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
checking for X... configure: error: chemichael Fedora 3 11-28-2005 01:52 PM
checking for Qt... configure: error Anden008 Linux - Newbie 4 11-15-2005 02:27 PM
checking for X...configure:error dumbsheep Linux - Newbie 4 02-01-2005 03:21 PM
./configure problem checking for libxml libraries >= 2.6.15 jackkerouac Linux - Software 2 01-12-2005 05:17 PM
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found Guitarist88 Linux - Newbie 2 08-13-2004 01:15 PM


All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration