LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-03-2010, 11:36 PM   #1
clubbing80s
LQ Newbie
 
Registered: Jun 2010
Distribution: Fedora 2 - 12
Posts: 8

Rep: Reputation: 0
Unhappy checking for C compiler default output... configure: error: C compiler cannot create


Hi
I have a 32 build build environment on fedora 12 64bit. The build environment is a complete system (unless the provider has missed something) .. I chroot into the build environment. When I run rpmbuild on any of the provided sources / spec files they exit with
"
checking for C compiler default output... configure: error: C compiler cannot create executables "
Or similar.

eg :
bash-3.00# rpmbuild -ba -v ./SPECS/expat.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.76344
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd /root/rpmbuild/BUILD
+ rm -rf expat-1.95.7
+ /bin/gzip -dc /root/rpmbuild/SOURCES/expat-1.95.7.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd expat-1.95.7
+ echo 'Patch #0 (expat-1.95.7-xmlcall.patch):'
Patch #0 (expat-1.95.7-xmlcall.patch):
+ patch -p1 -b --suffix .xmlcall -s
+ echo 'Patch #1 (expat-malloc-failure.diff):'
Patch #1 (expat-malloc-failure.diff):
+ patch -p0 -b --suffix .malloc -s
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.76344
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd expat-1.95.7
+ export 'CFLAGS=-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC'
+ CFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC'
+ CFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC'
+ export CFLAGS
+ CXXFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ export CXXFLAGS
+ FFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ export FFLAGS
+ ./configure --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --target=i386-pc-linux --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info
configure: loading cache /dev/null
/dev/null: line 1: ./configure:: No such file or directory
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for i686-pc-linux-gnu-gcc... no
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
error: Bad exit status from /var/tmp/rpm-tmp.76344 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.76344 (%build)
bash-3.00#

How do I resolve this ?

Greg
 
Old 07-04-2010, 12:56 AM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

It sounds like you need to get a C compiler. Something like this:
Quote:
yum install gcc g++ make automake autoconf libtool
'Hope that helps .. PSM
 
Old 07-04-2010, 03:31 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,519

Rep: Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495
.. And if gcc is present, find it with :
cd <top-directory-of-chroot-environment>
find ./* -iname *gcc*

Can also be a path problem ?

But, so far concerns expat-1.95 : It is available.

# yum install compat-expat1.i686 ( I guess )
It is on the file list for Fedora12 x86_64 :
compat-expat1-1.95.8-6.i686.rpm
( Also available: compat-expat1-1.95.8-6.x86_64.rpm )
You can check the required install name with :
# yum search expat
..

Last edited by knudfl; 07-04-2010 at 04:01 AM.
 
Old 07-05-2010, 08:17 PM   #4
clubbing80s
LQ Newbie
 
Registered: Jun 2010
Distribution: Fedora 2 - 12
Posts: 8

Original Poster
Rep: Reputation: 0
Hi
So far I found that running rpmbuild with the "--target i586" option works.

How can I set the chroot environment so that the compiler in the chroot env, thinks it's running in an i586 environment.

Thanks for the info.
 
  


Reply

Tags
bit, chroot, linux, rpmbuild


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: C compiler cannot create executables richlawson Fedora 14 02-22-2012 10:45 PM
checking for C compiler default output... configure: error: C compiler cannot create fiorejm Linux - Software 6 11-12-2009 12:35 PM
configure: error: C compiler cannot create executables brittanythepirate Linux - Software 10 11-07-2007 09:10 AM
configure: error: C compiler cannot create executables Geneset Linux - Newbie 7 07-13-2007 03:11 PM
configure: error: C compiler cannot create executables redsnapperke Linux - Software 11 06-05-2006 08:10 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration